RAID 0 array upgrade gone wrong

When I built my pc a few years ago I installed 2 80gb drives in a RAID 0 array for my operating system using the onboard driver of my ASUS m2n-sli deluxe MB. It is now time to upgrade my Windows XP x64 with larger drives. I purchased 2 150gb Raptors, built the array, formatted the "new drive", and cloned the old array to the new array using Acronis True Image. I then removed the old array from the system and moved the sata connectors from the new array to the same location of the original array.

Re-boot ---- nothing :(. (Missing NTLDR & boot.ini)

Next, I boot from Windows XP Pro x64 disk and enter the Recovery Console. Followed instructions found online for repairing missing boot.ini.
Ran CHKDSK (/p & /r { /f comes up invalid command?}) several times until no errors are found. Try to run "BOOTCFG /REBUILD" and get error messages saying drive has errors and cannot continue.

After numerous attempts over several days, I put the 2 "old"/original disks back into the system, this time in the place where the 2 "new" disks were when the drive was orginally cloned. Windows still shows "Missing Boot.ini", but attempts to load anyway. The Windows XP Pro x64 Login page comes up, but when I click on the Administrator, I get a message saying that I must activate Windows in order to continue. I click yes to activate, then it hangs up on that spot (still on the login page) & will go no further.

Now for my question:
Would it be possible for me to format my new RAID array and do a fresh load of Windows, then once I am able to login, recover my programs from a backup so that I don't have to re-install all of the programs. I'm not sure some will still even let me install them, because they are so old and are updates from older legacy versions.

Thank You and any suggestions would be GREATLY appreciated.
1 answer Last reply
More about raid array upgrade wrong
  1. RAID controllers/Software RAID are finicky at times - when changing ports in the RAID array - you have a good chance of losing your data. My suggestion for a project like this is to create an image of your original drive array in working order to another hard drive (external USB suggested), remove the old drives, install the new drives and create the array, then restore the image to the new array.

    I always suggest not to use RAID unless it is the only solution available. By that, in a production environment, using RAID 10 (striping & mirror) is the best solution - so when a drive fails, you can "hot-swap" and get back online quickly vs. restoring from a backup.

    At home, time isn't that critical, and with Windows Vista/7/8 and the Libraries, using multiple drives isn't confusing. The headaches that can happen from home use isn't worth while...
Ask a new question

Read More

NAS / RAID Boot Windows XP