Solved

Can't connect to game servers, but can surf internet.

Hi guys,

So three days ago, I experienced this problem that I can surf the web normally, but I can't connect to game servers, when I try to connect to game server, its like it disconnects from the game server alone, or times out. The games I am not able to play are:

1- DotA 2 (Used to play it normally)
2- CrossFire
3- HEAT Online (Worked once yesterday, but after restarting the router, it didn't work again)

Actually, sometimes they work, and sometimes they don't. But I still can surf the internet whenever I want.

My router is a WiiMax router (Good signal) and it is not connected to a modem. I haven't changed any setting in the router.

My AntiVirus: Avira Internet Security 2013, had it since January 2013 and no problems.

So what is this problem from? My computer? My Router? or my ISP?

Please help me ASAP

Best,
MJaoune
Reply to Anonymous
42 answers Last reply Best Answer
More about connect game servers surf internet
  1. I would check the firewall feature in Avira
    Try turning it off (if you have the Windows Firewall enabled)

    http://www.pcmag.com/slideshow_viewer/0,3253,l=304670&a=304670&po=4,00.asp
    Reply to hubbardt
  2. hubbardt said:
    I would check the firewall feature in Avira
    Try turning it off (if you have the Windows Firewall enabled)

    http://www.pcmag.com/slideshow_viewer/0,3253,l=304670&a=304670&po=4,00.asp


    Windows Firewall is already disabled. Disabling Avira Firewall didn't solve the problem.
    Thanks for trying to help me

    Any other suggestions guys?
    Reply to Anonymous
  3. Is it possible your router is blocking the ports you need to use to access your games? You could try opening those ports with the Port Forwarding feature of the router.
    Reply to mbreslin1954
  4. mbreslin1954 said:
    Is it possible your router is blocking the ports you need to use to access your games? You could try opening those ports with the Port Forwarding feature of the router.


    Nope :S Tried playing with port forwarding, no luck...
    Reply to Anonymous
  5. I have the same problem here. Does anyone have an answer?
    Reply to Charles Sian
  6. Charles Sian said:
    I have the same problem here. Does anyone have an answer?


    Same here, today was a tech here with his laptop and was unable to connect, but he has no answer to problem!
    Reply to Erik Causevic
  7. Are you in the US ? If yes, then there are three words they hate to hear by a complaining customer, Public Service Commission. The PSC regulates what they can charge, the more complaints, the less they potentially can charge.I've used those words before and it is amazing how the tone of their voice changes....don't go there unless you have to because you might have to call the commission and file a compliant. It's a pissing contest that you will win but you just want to play your game, be polite but firm...

    Wanna play hardball? Here is what we did...
    Using the PSC we were able to get back $60,000 when trying to resell T-1's. Bell South was the provider and our company would spend the time and money for marketing to land new customers for the T-1 resell. Bell South would give quality service at first then us lousy service which in turn provided the customer lousy service. Low and behold we started losing customers to guess who? Bell South.

    After losing 20+ customers to Bell South we thought that something was going on. After tracking past and present customers service it was clear that was the case. In the end the PSC awarded our company the $60K for their low life business practices.
    Reply to Beachnative
  8. Anonymous said:
    Hi guys,

    So three days ago, I experienced this problem that I can surf the web normally, but I can't connect to game servers, when I try to connect to game server, its like it disconnects from the game server alone, or times out. The games I am not able to play are:

    1- DotA 2 (Used to play it normally)
    2- CrossFire
    3- HEAT Online (Worked once yesterday, but after restarting the router, it didn't work again)

    Actually, sometimes they work, and sometimes they don't. But I still can surf the internet whenever I want.

    My router is a WiiMax router (Good signal) and it is not connected to a modem. I haven't changed any setting in the router.

    My AntiVirus: Avira Internet Security 2013, had it since January 2013 and no problems.

    So what is this problem from? My computer? My Router? or my ISP?

    Please help me ASAP

    Best,
    MJaoune
    Reply to Michael Hayden
  9. Best answer
    Problem solved!
    New IP from ISP provider and every thing work normal now!
    I had same problem with Heat online, it was impossible to visit site or run game, now solved!
    Reply to Erik Causevic
  10. Charles Sian said:
    I have the same problem here. Does anyone have an answer?


    I also have the same issue... no answer but definitely seems to be rampant. does anyone here understand or study the illuminati? just asking?
    Reply to nrgguyd
  11. I have this same problem, and there is no real solution listed here. Help?
    Reply to aaronfranke
  12. Change your ISP if you can.
    Reply to mbreslin1954
  13. Erik Causevic said:
    Problem solved!
    New IP from ISP provider and every thing work normal now!
    I had same problem with Heat online, it was impossible to visit site or run game, now solved!


    are u saying to change the entire ISP or actually just ask them to change your assigned IP address
    Reply to core001
  14. If you have a dynamically assigned IP address, i.e., it changes every time you disconnect and reconnect the modem from the ISP, then try turning off your modem, waiting two minutes, then turn it on again. It should get another IP address assigned to it when it reconnects.

    If you have a static IP address assigned to you (more expensive, typically comes with the Business service), then ask the ISP to give you a new one.

    If those fail, change ISPs if possible.
    Reply to mbreslin1954
  15. I belive i have the anser this happened to me and i found out that my system was having trouble with java try going to controlpanal then uninstal alljava things u see then re download java try java 7 and make sure u get the right one u probably need 64 bit ofline and online dosent matter much btw
    Reply to WillTheBeast
  16. I had the same problem, But I fixed it either after;
    Rebooting my modem (That would work temporarily)
    Or COMPLETELY shutting off my firewall. IF you only partly turn off your firewall, nothing will happen, you need to turn off the different modes; Public, Domain and Private. You can find the option to disable them in "Windows Firewall with advanced security",

    Hope this helped anyone else! :)
    Reply to Jacob Curtis M
  17. Anonymous said:
    Hi guys,

    So three days ago, I experienced this problem that I can surf the web normally, but I can't connect to game servers, when I try to connect to game server, its like it disconnects from the game server alone, or times out. The games I am not able to play are:

    1- DotA 2 (Used to play it normally)
    2- CrossFire
    3- HEAT Online (Worked once yesterday, but after restarting the router, it didn't work again)

    Actually, sometimes they work, and sometimes they don't. But I still can surf the internet whenever I want.

    My router is a WiiMax router (Good signal) and it is not connected to a modem. I haven't changed any setting in the router.

    My AntiVirus: Avira Internet Security 2013, had it since January 2013 and no problems.

    So what is this problem from? My computer? My Router? or my ISP?

    Please help me ASAP

    Best,
    MJaoune
    Reply to thekilling87
  18. i have the same problem i can surf etc... but my downloads for such as Utorrent and gaming does not work at all.. cant patch my games or get new updates FML..
    Reply to Sifumoua
  19. Control Panel\System and Security\Windows Firewall then Restore defaults
    then click the game and your windows should ask idf you want this program to get through the wall click yes and that should do it
    Reply to OverG
  20. I could not connect to a bunch of games servers.
    - Elder Scrolls Online
    - ArcheAge
    - Neverwinter
    - World of Tanks
    All there games would not update, show announcements or anything on the launcher..
    Until I went into my antivirus and reset it to default and it fixed all my problems!
    Hope it helps someone.
    Reply to BeefySteaks
  21. I am having the same problem and it's been a few months. It never works for any games that are online. Even my iPad and iPod games! My steam won't connect at
    all either unless it's through Google or my iPod. This has been happening ever since I got a new frontier router so I know that's the problem. However I have no idea how to fix this. I'm Getting sick of this now so if anyone has a solution please tell me.
    Reply to BrandonX
  22. So just built my computer the other day and Im having simular problems.

    I can surf the internet, download games skype people everything.

    I can't play any of the games, download java, or torrent anything.

    When I try to play these games they say can't connect. Any solutions please.
    Reply to ZachSavage
  23. same thing happened to me, was playing mw3 earlier that day then went back to play and could not connect, now all online games wont connect, i can use facebook and even tumblr and email but not twitter, nothing updated, nothing changed on that day except that im no longer able to connect to any games, its really messed up
    Reply to soundcrack
  24. OverG said:
    Control Panel\System and Security\Windows Firewall then Restore defaults
    then click the game and your windows should ask idf you want this program to get through the wall click yes and that should do it

    Thank you so much! I can connect to my games now :wahoo:
    Reply to Erit1566
  25. did not help me, still wont connect to game servers
    Reply to soundcrack
  26. I seem to have the same problem:

    I came home from school one day and an AT&T van was parked outside my neighbor's house. When I got inside, I found that my I could connect to my network or whatever but I couldnt connect to the actual internet. However, after restarting the modern and waiting a while, the internet came back on. However, I realized that I was unable to play games on my computer on my laptop and phone (league and clash). Anyone have any new solutions?
    Reply to Aerolus
  27. Anonymous said:
    Hi guys,

    So three days ago, I experienced this problem that I can surf the web normally, but I can't connect to game servers, when I try to connect to game server, its like it disconnects from the game server alone, or times out. The games I am not able to play are:

    1- DotA 2 (Used to play it normally)
    2- CrossFire
    3- HEAT Online (Worked once yesterday, but after restarting the router, it didn't work again)

    Actually, sometimes they work, and sometimes they don't. But I still can surf the internet whenever I want.

    My router is a WiiMax router (Good signal) and it is not connected to a modem. I haven't changed any setting in the router.

    My AntiVirus: Avira Internet Security 2013, had it since January 2013 and no problems.

    So what is this problem from? My computer? My Router? or my ISP?

    Please help me ASAP

    Best,
    MJaoune
    Reply to yorkie247
  28. It will be your routers fire wall turn it of then try your games, mine has just done the same. now sorted for now.
    Reply to yorkie247
  29. It will be your routers fire wall turn it of then try your games, mine has just done the same. now sorted for now.
    Reply to yorkie247
  30. i found out that i was only allowed a set amount of devices using the internet, and that limited my internet access, its all fixed now.
    P.S. it was a cell phone that was causing the issue lol, issue fixed right after its wifi was disabled.
    Reply to soundcrack
  31. soundcrack said:
    i found out that i was only allowed a set amount of devices using the internet, and that limited my internet access, its all fixed now.
    P.S. it was a cell phone that was causing the issue lol, issue fixed right after its wifi was disabled.
    Reply to yorkie247
  32. soundcrack said:
    i found out that i was only allowed a set amount of devices using the internet, and that limited my internet access, its all fixed now.
    P.S. it was a cell phone that was causing the issue lol, issue fixed right after its wifi was disabled.
    Reply to yorkie247
  33. Thanks for that but i sorted it, it was my virgin router it done an update and for some reason the firewall on the router was stopping me from playing games turned it off and all is good.
    Reply to yorkie247
  34. same thing are happening to me...
    Reply to Dimas_2
  35. Have you tried turning of your routers firewall? make sure you do a restart on the router when you turned it of and give it about 2 mins before you try again.
    Reply to yorkie247
  36. yorkie247 said:
    Have you tried turning of your routers firewall? make sure you do a restart on the router when you turned it of and give it about 2 mins before you try again.


    holy smokes if there are people out there that are trying to help other with this issue i must say that i am suffering from these computer symptoms myself
    recently ive gone into my cg1330-07 motherboard bios and i "reset factory defaults" and now all multiplayer games that i play like any Blizzard game or Steam game i get stuck here: "authentication: connecting to servers.................."
    i can still surf the net and connect to skype but for some reason non of my games will get passed this screen.
    ive turned off the firewall, ive reset windows firewall defaults, i pushed the button on my perfectly working router (no issues with other PCs on the network)
    i still havent tried asking my ISP for a new IP address but i dont see how that would help. not saying im not gonna call em tomorrow morning. its just im desperate here! I NEED MY GAMES DAMMIT and im gonna pull my hair out ! (only joking)
    Reply to snarkylark
  37. open your cmd as administrator
    >netsh i i r r
    >netsh winsock reset
    restart your computer
    Reply to snarkylark
  38. Erik Causevic said:
    Problem solved!
    New IP from ISP provider and every thing work normal now!
    I had same problem with Heat online, it was impossible to visit site or run game, now solved!


    I had this same issue too. Instead of having to get a new IP and ISP provider I just turn off my router and turn it back on. The problem still exists and comes back from time to time.
    Reply to Hydroplane72
  39. Erik Causevic said:
    Charles Sian said:
    I have the same problem here. Does anyone have an answer?


    Same here, today was a tech here with his laptop and was unable to connect, but he has no answer to problem!
    Reply to Han___sam
  40. snarkylark said:
    open your cmd as administrator
    >netsh i i r r
    >netsh winsock reset
    restart your computer


    idk what i did but it dosent work
    Reply to Mohamed_109
  41. 1 Solution from me.That was happening with me too but i can't fix it no solution did work finally i reinstall my window then i can connect to server.

    Reinstall your window Hope it will helpful.
    Reply to Hari_16
  42. jamesjordery@gmail.com
    Reply to james_414
Ask a new question Answer

Read More

Networking