Sign in with
Sign up | Sign in
Your question
Solved

3TB HDD Installation Problem on ASRock Z77 Extreme4

Last response: in Motherboards
Share
March 14, 2013 12:10:51 PM

Hi guys, first of all thank you all for seeing my post, and I'm very sorry to bring up an old topic, but I guess I could use some expert's help on this.
I was trying to install a 3TB HDD (WesternDigital RED 3TB HDD) to my new mobo (ASRock Z77 Extreme4). Whenever I got to drive configuration, it only let me to use the 2TB. (the rest was inaccessible, it wouldn't allow me to format it.) I know that I could easily use ASRock 3tb unlocker to unlock the missing part of the drive.
But that doesnt really help me since I want to make only 2 partitions configuration (200gb for C -for the OS- and 2.5tb for D, and the unlocker only lets me to make 3 or more partitions configuration in my case)

So I tried the UEFI boot thing, I finally got my hands on a copy of windows 7 with EFI folder (it is pirated version, just to see if it would work) I downloaded it to my flash drive, and made it bootable. On POST I pressed F11 and I found the UEFI: blah blah blah listed on the option. I selected it and hit enter but nothing happened. Tried several time but still no luck what so ever. I thought that the problem was my flash drive, so i burnt the windows to a dvd. This time no UEFI on boot selection, but AHACI: ..... (there were two of them, my hdd and my dvd drive)
I chose the dvd and hit enter, it successfully booted from the dvd, but it was still giving me that 2tb and inaccessible 7gb configuration.
I flashed my bios, and still nothing.

So, what do you guys think I should do?

my rig:
3570k
z77 ext4
hd7970 vapor x
2x4gb corsair vengeance 1866
wd red 3tb
naxn 750w

Best solution

a c 559 V Motherboard
March 14, 2013 12:20:24 PM

Hi, Shift +F10 at the Windows 7 installation screen for diskpart and GPT format the drive.
http://www.youtube.com/watch?v=D-HZV8JlQf4
or google for similar
Share
a b V Motherboard
March 14, 2013 4:07:49 PM

You should really get another another drive for the C drive. They are 5400 rpm as opposed to 7200 rpm. I use the REDs for storage and they are great but I would not like one for a system drive. Either a SSD or a 500GB 7200prm drive.

If you are going to use it anyway, do as alex has stated and to the change the drive size at install.
m
0
l
!