Sign in with
Sign up | Sign in
Your question
Solved

computer suddenly doesnt turn on

Last response: in Systems
Share
March 14, 2013 2:49:39 PM

I turned on my computer today and it suddenly stopped turning on. I opened up the case to check cables, but they seem fine. When i push the power, the fans move for a sec and stop. I already tested the psu by paperclip test and it worked. Is there anything i can do before i rma the entire pc.?
March 14, 2013 3:01:49 PM

disconnect the power cable for a few mins, then reconnect it and try to boot. if that doesn't help you can try booting with no drives connected to motherboard, and also try removing all but 1 ram chips.

what kind of system is this?
m
0
l
March 14, 2013 3:17:59 PM

daswilhelm said:
disconnect the power cable for a few mins, then reconnect it and try to boot. if that doesn't help you can try booting with no drives connected to motherboard, and also try removing all but 1 ram chips.

what kind of system is this?


ok i tried all that and did not boot

my system is by cyber power 1337 gaming pc
i7 3770k
8gb ram
b75m d3h,motherboard
amd7770
m
0
l
Related resources
March 14, 2013 3:23:31 PM

if u have another psu around, you could try that.
or if there is a clear cmos jumper on the motherboard, try that as well
m
0
l
March 14, 2013 3:26:06 PM

daswilhelm said:
if u have another psu around, you could try that.
or if there is a clear cmos jumper on the motherboard, try that as well


thanks for your help!
what do you mean by cmos jumper, im not very good at computers.
also i dont have a spare psu
m
0
l
March 14, 2013 3:27:40 PM

Do you have a speaker connected to the motherboard? If so, any beep pattern when it shuts off?
m
0
l
March 14, 2013 3:34:48 PM

slomo4sho said:
Do you have a speaker connected to the motherboard? If so, any beep pattern when it shuts off?


nope, no beeps. when i push power, thebutton flashes for a split second and the fans turn slightly.
thx for your help tho
m
0
l

Best solution

March 14, 2013 3:38:53 PM

Hoboeater said:
slomo4sho said:
Do you have a speaker connected to the motherboard? If so, any beep pattern when it shuts off?


nope, no beeps. when i push power, thebutton flashes for a split second and the fans turn slightly.
thx for your help tho


Then the likely culprit is the PSU and the less likely is the motherboard. I guess we wait until you get a new PSU to test further.
Share
March 14, 2013 3:42:33 PM

slomo4sho said:
Hoboeater said:
slomo4sho said:
Do you have a speaker connected to the motherboard? If so, any beep pattern when it shuts off?


nope, no beeps. when i push power, thebutton flashes for a split second and the fans turn slightly.
thx for your help tho


Then the likely culprit is the PSU and the less likely is the motherboard. I guess we wait until you get a new PSU to test further.


But i thought the paperclip test could be used to check, also would checking it with a meter help?
otherwise i may just RMA it, i just didnt want to wait a month :( 
m
0
l
!