Closed Solved

AMD Radeon hd 5830 displayport not working

I am trying to connect a third monitor to my computer but the computer will not even recognize the dp to active dvi is plugged it. There is no sound from windows when you normally plug in a new device. The active dp to dvi I am using is this. http://www.newegg.com/Product/Product.aspx?Item=N82E16812200949 This is on the apporved list of adapters. I have catalyst 13.1 windows 64 bit and trying to connect my monitors in this way. monitor 1 dvi monitor 2 hdmi monitor 3 dp to active dvi.

Thank you
8 answers Last reply Best Answer
More about amd radeon 5830 displayport working
  1. Which card specifically?
  2. Spaniard United said:
    Which card specifically?


    http://www.newegg.com/Product/Product.aspx?Item=N82E16814125317
  3. Any chance you can try changing your HDMI cable to a DVI cable? Shot it the dark, but I've had weird things happen with HDMI and Eyefinity.
  4. Also kind of an obvious question, but have you checked to make see the third monitor is enabled Catalyst? Theoretically, it should just automatically go as an extended monitor, but obviously something isn't working right for you.
  5. Like when I connect the DP adapter the computer doesn't even register that it is there. If I try to do a hardware search it doesn't find anything.
  6. Best answer
    Try unplugging your HDMI or DVI monitor and using the DVI cable you have attached to your adapter by itself. If the DVI cable transmits the signal to that monitor without the adapter, then we'll know you got a bad adapter.
  7. Seems like it is still not working. Probably a bad adapter then. Thank you I didn't know if it was just the adapter or my card. I will contact the people for the adapter. Thank you for helping me.
  8. Aiizawa said:
    Seems like it is still not working. Probably a bad adapter then. Thank you I didn't know if it was just the adapter or my card. I will contact the people for the adapter. Thank you for helping me.


    I had the same issue using a DisplayPort to DVI adaptor, I uninstalled the 13.1 drivers and rolled back to version 12 (12.6 i believe?) and it works fine!
    Seems something about 13.1 isn't quite right...
Ask a new question

Read More

DVI 5830 AMD Connection Computers HD Graphics Monitors DPI Radeon