Sign in with
Sign up | Sign in
Your question

Low Fps PLaying Warcraft (WoW) on Medium Settings

Last response: in Video Games
Share
March 14, 2013 6:59:06 PM

Hello, I am experiencing really low fps issues while playing WoW. The fps is fine when I'm flying around and questing (30+ fps questing, 60+ fps doing nothing), but when I get in a raid of 25 mans it dips into the teens. (12-20 fps while I was monitoring it). Also, it is virtually unplayable with the new 40man+ world bosses, my screen pretty much freezes. My system is a little old, but I thought I would get better numbers than this. I'm running with...

Processor: Amd Athlon II x4 620 @2.60 Ghz
Ram: 6.00 GB DDR2 DRAM Frequency: 400mhz
GPU: Galaxy Nvidia GeForce GTS 450
PSU: Mushkin Enhanced 650W
Motherboard: Pegatron Corporation, Violet 3.02
OS: Windows 7 Home Premium 64 bit

All game settings are from Good to Low.
Vsync is off and shadows on Low.
1280x720 windowed mode at the moment.


I ran GPU-Z and the GPU load is constantly sub 30% so I dont think that the GPU is the problem. Plus I installed a GTX 660 and the fps still dipped into the teens sometimes. I also ran a memtest for the Ram and everything came back fine. My GPU driver is up to date and I checked sound/internet drivers as well. Is my processor just old, and I need to upgrade my mobo/processor/ram? Please help! I am out of ideas :'( 

More about : low fps playing warcraft wow medium settings

March 14, 2013 7:15:11 PM

I think you answered your own question almost, yes it is time for an upgrade, but what about your internet speed? use www.speedtest.net if it is lower than 5M down, you better off getting faster internet first
m
0
l
March 14, 2013 7:45:18 PM

Really? Thats interesting. I played wow back in cata (haven't tried MoP and don't intend to) and I have an athlon 2 x3 445 + 6870, 60fps anywhere, BGs, arenas, WG/TB. Heck I was even able to record at a decent FPS (IE never below 30fps)

I was on either ultra settings or High, I am almost positive it was a mix of ultra and high though.

But like I said this was in cata. The 450 isn't a very good gpu, specially not by todays standards.

Edit: Just saw your cpu is @ 2.6ghz... That might be part of the problem. Though the gpu is still very meh.
m
0
l
Related resources
March 14, 2013 7:49:47 PM

U def need a processor, I had an x3 440 and that bottlenecked the 5770 I had at the time. Get a nice 990fx board and a Phenom 965be and dual channel ddr3 2x4gb... can't link anything from my phone, will do when I get home
m
0
l
March 15, 2013 9:22:20 AM

mouse24 said:
Really? Thats interesting. I played wow back in cata (haven't tried MoP and don't intend to) and I have an athlon 2 x3 445 + 6870, 60fps anywhere, BGs, arenas, WG/TB. Heck I was even able to record at a decent FPS (IE never below 30fps)

I was on either ultra settings or High, I am almost positive it was a mix of ultra and high though.

But like I said this was in cata. The 450 isn't a very good gpu, specially not by todays standards.

Edit: Just saw your cpu is @ 2.6ghz... That might be part of the problem. Though the gpu is still very meh.

wow is a more cpu bound than gpu. with my x3 i could only get 66% load on the card and about 50-60 fps.. when i upgraded to 3770k with the same card i got 100% usage of the card and 90-110 on high settings 1080p
m
0
l
March 15, 2013 9:28:04 AM

Thanks for all the help/replies! I had no idea WoW was more Cpu bound than Gpu. Ugh, time to shop around i guess. Thanks again everyone that helped :) 
m
0
l
!