AMD Catalyst Control Centre WILL NOT WORK

I have tried everything, I cannot get this stupid control center to work. It is supposed to give me graphics options like anti aliasing and overclocking, but the only tabs I get are: Pinned, Presets, Desktop management, Common display tasks, Video, Audio, Information. No graphics, gaming, whatever. I have tried with the most up to date drivers and I have tried with 12.6, which tells me it isn't up to date when I open CCC yet when I go through device manager it says it is up to date.


WTF is wrong with this graphics card company, I should've got an Nvidia :(

My card is Radeon HD7870 2GB OC edition. I am very unhappy as the performance of this card is not meeting expectations, I have seen videos on youtube of it running Assassin's Creed 3 at max settings at 1080p, I can only play it at medium settings 720p without recording.


Any fix for this extremely frustrating problem would be appreciated. I need to fiddle with settings / overclock to get this card where it should be
6 answers Last reply
More about amd catalyst control centre work
  1. when you download drivers, do not use windows downloads. download directly from the AMD website. the current wqhl drivers are 13.1. the current beta drivers are in 13.2 beta 7. for naming reference, the digits before the period represent the year the driver was released, and the number after is the month.

    also when removing the amd driver, i recommend downloading amd's official catalyst uninstaller before installing the current drivers.


    I WILL ALSO NOTE that Assassin's Creed 3 is a poorly optimized game. Ubisoft in general is really slow to patch their games and make it run effectively. Its taken a while for far cry 3 to be fixed and technically it still hasnt been optimized yet.
  2. Free_Hidings said:
    I have tried everything, I cannot get this stupid control center to work. It is supposed to give me graphics options like anti aliasing and overclocking, but the only tabs I get are: Pinned, Presets, Desktop management, Common display tasks, Video, Audio, Information. No graphics, gaming, whatever. I have tried with the most up to date drivers and I have tried with 12.6, which tells me it isn't up to date when I open CCC yet when I go through device manager it says it is up to date.


    WTF is wrong with this graphics card company, I should've got an Nvidia :(

    My card is Radeon HD7870 2GB OC edition. I am very unhappy as the performance of this card is not meeting expectations, I have seen videos on youtube of it running Assassin's Creed 3 at max settings at 1080p, I can only play it at medium settings 720p without recording.


    Any fix for this extremely frustrating problem would be appreciated. I need to fiddle with settings / overclock to get this card where it should be


    What CPU are you running?

    In CCC have you enabled "advanced" view?
  3. dudewitbow said:
    when you download drivers, do not use windows downloads. download directly from the AMD website. the current wqhl drivers are 13.1. the current beta drivers are in 13.2 beta 7. for naming reference, the digits before the period represent the year the driver was released, and the number after is the month.

    also when removing the amd driver, i recommend downloading amd's official catalyst uninstaller before installing the current drivers.


    I WILL ALSO NOTE that Assassin's Creed 3 is a poorly optimized game. Ubisoft in general is really slow to patch their games and make it run effectively. Its taken a while for far cry 3 to be fixed and technically it still hasnt been optimized yet.


    Thank you, I have done this though. Downloaded drivers direct from the site, haven't tried the beta yet but I imagine it won't fix the problem. I have been uninstalling catalyst from the AMD application so it should be doing it properly, and even running CC cleaner in between.

    americanbrian said:
    Free_Hidings said:
    I have tried everything, I cannot get this stupid control center to work. It is supposed to give me graphics options like anti aliasing and overclocking, but the only tabs I get are: Pinned, Presets, Desktop management, Common display tasks, Video, Audio, Information. No graphics, gaming, whatever. I have tried with the most up to date drivers and I have tried with 12.6, which tells me it isn't up to date when I open CCC yet when I go through device manager it says it is up to date.


    WTF is wrong with this graphics card company, I should've got an Nvidia :(

    My card is Radeon HD7870 2GB OC edition. I am very unhappy as the performance of this card is not meeting expectations, I have seen videos on youtube of it running Assassin's Creed 3 at max settings at 1080p, I can only play it at medium settings 720p without recording.


    Any fix for this extremely frustrating problem would be appreciated. I need to fiddle with settings / overclock to get this card where it should be


    What CPU are you running?

    In CCC have you enabled "advanced" view?


    Intel Core i5 3750k (stock)

    Yes, that was the first thing I tried, haha thanks.
  4. Seems a very strange problem this, i have done some searches and like the other guy said, it generally only happens when you let windows install a driver from microsoft. I don't know about you, but every time i install a major component like a new GPU, i do a fresh install of Windows, but thats just me. Try using driver sweeper http://www.guru3d.com/content_page/guru3d_driver_sweeper.html to remove all drivers, i very much doubt its a problem with the card.
  5. Assassins creed III has a DX10 mode . Which helps to attain fairly high fps than DX11.


    1. in win 7 Goto documents/assasin's creedIII/assasin3.ini
    edit 1st line from [Graphics_DX11] to [Graphics_DX10]
    2. right click game shortcut
    edit "target" field
    change AC3SP.exe" to AC3SP.exe" -dx10
    :)


    I am on HP G6 2010AX Notebook. I got like 12 fps in DX11 in performance mode , But managed to get ~25Fps on powersaving mode using DX10
  6. Having the same problem myself. I too have tried uninstalling and reinstalling. I have tried the beta that came out on the 15th. I tried some fix that had me hiding and unhiding files. Nothing seems to bring it back which is really upsetting because I can't re-activate my eyefinity.

    I was wondering if this could be related in any way to .net framework and installing microsoft software packages for it. I had done that shortly before installing the new drivers. This only started for me after I installed the newest CCC drivers, I assume the same is true for the OP.
Ask a new question

Read More

Catalyst AMD Graphics