problem with graphic card ATI Radeon HD7770

I built pc on my own but Mobo cant see it or not support graphic card, monitor always shows me "no signal 1900x1080 60hz recomended" My bios is up to date, drivers working perfect but that card protesting somehow and i do not have clue what is it.

My system: AMD Phenom II x4 965 BE
ASUS M5A78L-M USB3
RAM Crosair 2x4Gb 1600mhz
PSU G7 780W
and Asus Radeon HD 7770 DirectCU Graphics Card (1GB GDDR5, PCI Express 3.0, 1020MHz/4600MHz) CrossFire

Please help me someone
5 answers Last reply
More about problem graphic card ati radeon hd7770 crossfire
  1. Uhm.... that board only has one PCIe slot.. how did you put both cards in? Probably because your motherboard doesn't support two cards is why you are having your issue.

    http://www.asus.com/Motherboards/M5A78LMUSB3/#overview
  2. Milibili said:
    I built pc on my own but Mobo cant see it or not support graphic card, monitor always shows me "no signal 1900x1080 60hz recomended" My bios is up to date, drivers working perfect but that card protesting somehow and i do not have clue what is it.

    My system: AMD Phenom II x4 965 BE
    ASUS M5A78L-M USB3
    RAM Crosair 2x4Gb 1600mhz
    PSU G7 780W
    and Asus Radeon HD 7770 DirectCU Graphics Card (1GB GDDR5, PCI Express 3.0, 1020MHz/4600MHz) CrossFire

    Please help me someone


    Which port are you using with which cable? I am sure you only have the one card and the fire is a typo.
  3. he might be using the 1x slot
  4. JJ1217 said:
    Uhm.... that board only has one PCIe slot.. how did you put both cards in? Probably because your motherboard doesn't support two cards is why you are having your issue.

    http://www.asus.com/Motherboards/M5A78LMUSB3/#overview


    Novuake said:
    Milibili said:
    I built pc on my own but Mobo cant see it or not support graphic card, monitor always shows me "no signal 1900x1080 60hz recomended" My bios is up to date, drivers working perfect but that card protesting somehow and i do not have clue what is it.

    My system: AMD Phenom II x4 965 BE
    ASUS M5A78L-M USB3
    RAM Crosair 2x4Gb 1600mhz
    PSU G7 780W
    and Asus Radeon HD 7770 DirectCU Graphics Card (1GB GDDR5, PCI Express 3.0, 1020MHz/4600MHz) CrossFire

    Please help me someone


    Which port are you using with which cable? I am sure you only have the one card and the fire is a typo.
  5. it was faulty card...
Ask a new question

Read More

Systems Radeon Graphics Cards Crossfire ATI