Cloning UEFI RAID1 Array Windows 7 GPT Drive?

Has anyone successfully cloned a UEFI RAID1 array with a Windows 7 GPT partition to a new UEFI RAID1 array? If so, what software did you use? I am looking for a preferably bootable and free software to get this done.
I am using a Gigabyte GA-Z77-D3H motherboard.

The reason I want to do this is because after trying to use my bootable Paragon Drive Backup 8.5 (probably too old for UEFI) to create a backup image my new system, it ironically rendered my Windows unbootable! I didn't even get to use it or do anything with it. It loaded and could not read the drive, so I closed it. Yet somehow just booting to Paragon was enough to damage my windows bootloader or something! I have always had great success repairing boot issues, but not this time. After 2 days of trying to get the windows to boot again, using built in Windows Recovery and every recommended command prompt solution I could find online, I have decided that my last resort is to install Windows on a new RAID1 array (already done now), and then clone the first two system partitions onto the old array and hope it will boot!

I am trying to avoid installing everything from scratch on my new system because (besides having ALL the software installed and configured) I have a specialised clinic management software remotely installed and activated (license) by the software vendor, and they were a pain in the behind to deal with and I do not want to deal with them again if I can avoid it :( .
Any help will be greatly appreciated!!

This is my first post ever on this forum. I hope I have posted my question in the appropriate place and I am not breaking any rules. I did try to find answers in this forum and everywhere online, with little to no luck.
5 answers Last reply
More about cloning uefi raid1 array windows gpt drive
  1. Be careful.

    If you CLONE the new partition to where the damaged copy of Windows is you'll simply overwrite the old partition with the new copy of Windows. You also didn't need to use RAID for the new copy. I think you meant "replace" some of the key files not the entire partition?

    You basically have two options:
    1) REPAIR the damaged version of Windows
    2) OVERWRITE just the damaged component such as the Bootloader

    *REPAIRING:
    1) Boot to Windows 7 Install DVD
    2) choose "repair" option
    3) choose "System Restore" option

    Also, try repairing the boot loader manually: http://www.howtogeek.com/howto/32523/how-to-manually-repair-windows-7-boot-loader-problems/

    Overwriting:
    1) Boot to new Windows
    2) unhide system files
    3) copy/paste to the damaged Windows version
    *You need to Google this further. If you overwrite the wrong file you'll NEVER get this working again.

    Question:
    What happened when you did the SYSTEM RESTORE option from your Install disc?
  2. Thanks for your input photonboy. Much appreciated.

    I already did attempt the first option of booting with the Windows 7 DVD and trying the Auto Startup Repair and System Restore.
    First time it did process a Auto Startup Repair, but it didn't help. Then it did process a System Restore, and that didn't help either.
    Thereafter, it fails to complete a System Restore and Auto Startup Repair fails with this response "startup repair cannot repair this computer automatically".
    I had also tried the same steps described in the link you posted.

    I don't want to clone the whole drive, just the hidden partitions that are 100MB (part of Windows 7) and 128MB (part of GPT File System).
    I am hoping this will allow windows to boot again while retaining all the original files and settings of that installation.

    And I created a new RAID1 Array to make sure it is as close a match as possible to the original setup.
    Now, I got ready to do just that, I have installed Windows to a new Raid1 Array, and installed Windows on yet another drive which I am booting into. Result is I have the following connected:
    1) RAID1 Array (2 drives) with the corrupted Windows 7 boot partition.
    2) RAID1 Array (2 drives) which is fully functional and bootable Windows 7.
    3) Single drive also with a fresh install of Windows 7, I am booting into this and intend to clone from here.
    4) A spare and blank drive also connected for any extra (temporary) cloning steps that may be needed.

    So I don't even need to clone the partitions from the drive I am booting windows with, to avoid any locked files/partitions or complications! :)

    Now here is the interesting developement. Just as Paragon Partition Magic 8.5 first reported, when I run EaseUS Partition Master Home Edition 9.2 from windows, it reports the Original RAID1 as "Unallocated" GPT. Same thing was being reported when I used a bootable Gparted Live (Gnome Partition Editor), so I had assumed Gparted was unable to detect the combination of UEFI and RAID1.
    But, using windows explorer, I can access all the files on the 3 Primary Partitions on that Raid Array! And both Windows Install Disc would show both system partitions and my 3 Primary Partions and Disk Management from the Windows Computer Management shows them all (except the 128MB GPT partition, which is normal) as well.

    So, now I am unable to Clone the new system partitions over the old ones. EaseUS does offer a "Recover Partition" option that did detect the first partition during the first seconds of scanning before I interrupted it. I am hesitant to use this as i never have before.. I think I will use the spare drive to experiment on before I go ahead and use this tool on my main RAID Array.

    Oh, and earlier I did create a bootable EaseUS DiskCopy Home Edition, but it would see my drives as single drives rather than a RAID Array.
  3. Great!!

    Paragon Backup and Recovery 2012 (free version)(Windows) was able to see the partitions as they should be. Although it does not do a disk to disk clone, I created a backup image of my entire first Raid Array (which has the corrupted boot partition) and then restored the image to the spare HDD.
    And now I am able to boot my original windows and software from the spare drive! :)

    So next, I will attempt to repair the original Raid Array and if that fails I will just wipe it and restore from this backup image!

    What a relief.. finally! Spent 3 days on this with only about 6 hours worth of sleep since Thursday night...

    I will leave one last message when I have everything back on my original RAID1 , to report my final observations..
    It might help someone else someday.
  4. Trying to repair the Original RAID Array using the "Recover Partition" (quick scan) option of EaseUS Partition Master Home Edition 9.2 (windows) would not work. It would detect only the first partition (100MB) and would report that it recovered it successfully and I would see the partition in its own drive map, but, as soon as I would click OK to exit the recovery wizard, the partition would disappear again! The quick scan took about 10 or 15 minutes, I didn't have time to attempt a Full Scan.
    This behaviour leads me to suspect that the problem was not with the system partition, but rather the first sector or cluster (can't remember which it is) of the HDD that stores the RAID Array information that was corrupted. Although according to the RAID Controller BIOS and the raid management software of Intel (windows) (can't recall its correct names right now), the RAID Array was healthy. This is the only reason I can think of that would cause most software to not detect the Array and its Partitions and Data.

    So, in the end, this is what did work:
    Paragon Backup and Recovery 2012 (free version) (Windows) was able to see the partitions as they should be. Although it does not do a disk to disk clone, I created a backup image of my entire first Raid Array (which could not boot). I tested this image by restoring it to a spare HDD and then was able to boot from this spare drive and all my original data and software was intact.
    Next I deleted the Original RAID Array from the Intel RAID Controller BIOS and recreated the Array. Then I restored the recovery Image back to the new Array. Everything worked out fine and I had my original setup back.

    One not so important kink I experienced was that during my first attempts to fix my boot issue with the original RAID Array, I did a system restore through the Startup Repair options of the Windows 7 DVD. After backing up and restoring using Paragon Backup and Recovery 2012, System Restore was disabled (I found that it was holding on to restore points that it could not link to my current C drive, and instead was reporting that they belonged to a "Missing C: Drive". So I was unable to undo my last system restore operation which did cause me to lose some software configurations I had made since the last Restore Point was created before my troubles began.
  5. Apparently, I cannot select my own answer as "The Solution" and mark this thread as "Answered". So if someone could quote my previous message, I can select your message and "The Solution" and mark this thread as "Answered", and maybe it will help someone else someday.. :)
Ask a new question

Read More

Windows 7 Software Storage