Suddenly all games CTD on load

So this is weird... I've been running all sorts of modern games, from Skyrim to Battlefield 3 and even Crysis 3, but a few days ago all the games began CTD'ing whenever I enter them. It's weird because with Skyrim it's after the Bethesda logo so I don't even get to see the main menu. On BF3 it's first when it reaches the 'loading level' part, but it does show the small loading square in the corner of the screen before crashing. In Crysis I can jump around the menus and it only crashes when it's supposed to allow me to press Enter to begin my game after loading (from SP, haven't tried MP yet).

I use a GTX 660 Ti from EVGA and I haven't been having any problems before this, it just seems to have suddenly happened. I recall installing the latest beta driver for the card and I also tried to download the latest stable release (.07 or something, beta was .21 I think), but nothing changed with that downgrade. I reinstalled the beta driver because why not? Video playback and the entire Pc seems to work exactly as supposed to, it's just the games that crash without notice and I get no error messages at all.

Does anyone have an idea on what could be causing this?

EDIT: By the way... I'm on Windows 8, I suppose that could have something to do with it? -_-'
3 answers Last reply
More about suddenly games ctd load
  1. So this happened just after the driver upgrade? I suggest totally uninstalling the card and drivers and then reinstall newest none beta drivers.
  2. Damn, it still doesn't work... Uninstall, restart, re-install of non-beta drivers, no problems with the installation and still the same result as before :(
    Any other suggestions? : /
  3. Hi,

    This is for Crysis 3 level load error. You can resolve the problem by applying the solutions given in the reputed blog's article. You can access this article from here http://www.backspacetab.com/crysis-3-level-load-error/
Ask a new question

Read More

Battlefield Drivers ctd Games Nvidia Gtx Graphics