Sign in with
Sign up | Sign in
Your question

Home built computer works fine for 3 months, now it won't start!

Last response: in Systems
Share
March 18, 2013 3:02:54 PM

So I built my first ever computer about 3 months ago. Was very nervous and paranoid while building, but thankfully it seemed like I did everything fine and it ran like a charm!
However, I went to turn it on last night and ABSOLUTELY nothing happens. No lights, beeps; anything.

I tried to externally start up some of the components earlier today. I took out the motherboard from the case, and only had one stick of RAM and the CPU in it. Still, NOTHING happens. No lights, beeps, or anything.

I used the paper clip trick to test my PSU, and it started fine. The fan was running fine and there were no weird noises or anything, so I assume my PSU is not at fault. I also switched the slots of where the RAM was located and tried turning the Mobo on, but nothing worked. (Although, I never tried turning it on without ANY ram in)

Right now, it seems as if something happened to my mobo, but I could certainly use some advice/help.

My computer specs:
CPU = AMD FX 6300
MOBO = AsRock 970 Extreme4
GPU = MSI Radeon R7770 2PMDIGD5
RAM = 2x Kingston HyperX 4gb
PSU = Corsair CX500
HD = Seagate Baraude, 1TB 7200rpm
Optical drive = Sony DVD burner
OS = Windows 7

Let me know if I can provide any more information. I'm by no means savvy with computer building, so there's a chance I put this thing together wrong when I first built it; but for it to work 3 months and now suddenly NOTHING works is so confusing!!

Thanks for any help!
a c 101 à CPUs
a c 82 V Motherboard
March 18, 2013 3:24:42 PM

Sounds like the MB to me if the PSU is fine, and everything is dead and no beeps, I usually go MB next. I have a PSU tester though which is nice to know if everything is working on the PSU. Just because the paperclip jumps it, doesn't mean the 12v line or 5v line, etc are fried.
m
0
l
March 18, 2013 4:16:17 PM

I had the same problem with an AsRock try turning it on with no RAM. It should make three long beeps then re-install RAM and it should let you into BIOS. Check your RAM frequency and make sure it is set right mine kept defaulting to 1333 when it was supposed to be 1600.
m
0
l
Related resources
!