Sign in with
Sign up | Sign in
Your question

Weird Problem With My System!

Tags:
  • Intel i7
  • Minecraft
  • Intel
  • Components
  • Internet
  • Motherboards
Last response: in Motherboards
Share
March 22, 2013 10:14:45 AM

Hello guys, it's my first time around here! I have a PC that has the following components:

Intel DH67CL
Intel i7 2600 (not K)
MSI GTX570
Kingston 16 GB Ram
Using Windows 8

The issue is that my internet connection works in mysterious ways. My friend and I make Minecraft videos and upload them to Youtube. We usually play on some servers for Hunger Games or MineZ. I started to have connection issues about 2 months ago. I used to lose connection to the server once in a while however nowadays I can't even stay connected for 1 second. My friends say that I can move and chat however I can't see other people doing those things. I think I might not be receiving data from the server. I thought that my motherboard could be causing the issues so I tried installing a LAN network card but that did not resolve the issue. Another problem I face is when I am uploading to Youtube it is extremely slow while my other computer (a macbook pro) can upload much faster. I am out of ideas about this. I hope somebody might help me.

More about : weird problem system

March 22, 2013 10:22:56 AM

Well you've ruled out NIC driver issues, but go further and try these things:
Replace the network cable
Restart the router, even though other devices work fine it could still be the router.
Try another port on the router
If all else fails, get a network card and see if that solves the issue.
m
0
l
March 24, 2013 1:05:23 AM

leo2kp said:
Well you've ruled out NIC driver issues, but go further and try these things:
Replace the network cable
Restart the router, even though other devices work fine it could still be the router.
Try another port on the router
If all else fails, get a network card and see if that solves the issue.

I used a network card but no use... I will try to change the cable
m
0
l
!