Sign in with
Sign up | Sign in
Your question

Problem with CPU fan.

Last response: in CPUs
Share
March 28, 2013 8:08:00 AM

Alright, so last night I was just browsing the internet and all of the sudden my screen completely froze so I shut off my computer. When I turned it back on, the little mobo speaker that signals whether it's working or not was just beeping over and over again and I noticed the CPU fan wasn't on. The computer then turned its self off and then back on again the beeping continued and the cpu fan still wasn't working. It just kept doing that over and over again. I tried plugging the cpu fan into another fan socket to see if the cpu cooler was working and it did, but any other fan in the cpu fan socket wouldn't turn on.
So this morning I tried turning it on again and the same deal. I took the cpu fan out and and put it back in upside down and it's working fine now.
I'm afraid this will happen again, anyone got any ideas why it happened in the first place?
My computer is a pretty new build. I put it together about 3-4 weeks ago and it has been working fine up until this incident.

Specs:
I5-3570k
Gigabyte Z77-DS3H mobo
MSI Radeon HD 7770 Ghz edition
Corsair Vengeance 2x4gb ram
WD Caviar Black 1 tb
Cooler master 500w psu
Thermaltake V3 Black edition case
Intel stock cpu cooler.

More about : problem cpu fan

March 28, 2013 9:18:28 AM

If it works upside down then there may be something clogging it or defective with the fan


return the mobo and say it has a faulty cpu cooler pin. if that doesn't work return the cpu and say the fan as faulty. No point in trying to 'fix' it you are still covered by warranty, where did you buy it from?

return the fan first it seems to be defective, do you have any spare cpu coolers laying around to test?
m
0
l
March 28, 2013 9:19:02 AM

Sometimes there are fan controls specifically for the CPU fan socket in the BIOs. You may need to adjust that. I would start there. It is possible that something could be wrong as well, but defiantly start with the easier solution first. Check the BIOs settings. Good luck!
m
0
l
March 28, 2013 9:53:42 AM

Well the cpu fan isn't defective because I plugged it into other slots and it would work fine. I think it was the socket because when I plugged the other fans into the cpu fan socket they wouldnt work either. but like I said it's all working fine now so I don't understand.
m
0
l
!