Sign in with
Sign up | Sign in
Your question

LPT-Parallel Printer on USB Port issue (Win7 x64)

Last response: in Computer Peripherals
Share
March 29, 2013 6:08:06 PM

Hello there, my friends,

My friend has this old Epson LX300 Printer, which connects to the PC with parallel port. He uses it in his business, so it's kind of important to have it working.

I got him new pieces of hardware, and the new motherboard does not have the parallel port (lpt). Then, I bought this generic parallel to usb adapter on ebay (like this: http://www.ebay.com/itm/NEW-USB-TO-25-PIN-FEMALE-PARALL...).

However, after properly connecting everything, it didn't work as I expected.

First of all I turn on the printer, connect it to the adapter and, as I connect the usb side to the PC, it finds the "USB Printing Support" on device manager, the same way as every USB printer, however the windows popup says something like "No printer found" in that little window.

Then, I go to "devices and printers" and find this "USB2.0-Print", which can't be used to print anything.

I tried to google for the issue and found some people with the same problem, but most of them didn't solve it, and the others didn't explain properly how they fixed it, but it looks like there might be some driver messing involved.

I myself tried to download some drivers and to add manually the printer to the USB Port, but it didn't work. While messing around, the printer made some noises, but didn't print anything.

Is there any solution to this issue?
Thanks.
Related resources
March 29, 2013 8:17:29 PM

get a old jetdirect "print server". You can get one on ebay pretty cheap, and then just put the printer on the network.
m
0
l
March 31, 2013 6:06:50 PM

Hello there, friends.

I have figured out a way to make it work with that Parallel -> USB cable.

I had to manually add the printer with USB002 and then use Epson LX Series 1 (80), it's working now (LX 300+/II won't work).

Thanks.
m
0
l
!