ASRock P67 Pro3 Code 19 Error

Hi,
I ordered an ASRock P67 Pro3 off of ebay a few months ago, along with RAM. It didn't work due to a code 19 error, so I contacted ASRock tech support and they sent me a new one. I was working on putting it together today, and it too displayed a code 19 error on the debug. My build is as follows;

ASRock P67 Pro3
Intel Pentium G630 CPU
4GB G-Skill Ripjaw RAM
Okia 600W PSU

I'm not too sure about the CPU, as it's been used before (not by me). I'm not really keen on buying a new CPU (they're EXPENSIVE), so any help would be greatly appreciated. Thanks!
12 answers Last reply
More about asrock p67 pro3 code error
  1. IT's not the cpu, because code 19 is past the cpu initialization stage and before memory. Try it with only one memory stick.
  2. noidea_77 said:
    IT's not the cpu, because code 19 is past the cpu initialization stage and before memory.


    Oh thank god. The manual said that code 19 was pre-memory south bridge initialization, so I was under the impression that there was an issue with that portion of the CPU.

    noidea_77 said:
    Try it with only one memory stick.


    I just tried each stick in all four ports to no avail. I'll go check to see if I have any other available RAM that would fit. Thanks for the quick reply.
  3. I just tried it with a new stick of RAM, and I'm still getting the code 19 error. None of the sockets gave me anything different.


    It might be worth adding that now it returns 09 instead of 19 every now and then. Turning the comp off and on again brings it back to 19, though.
  4. Hi, The CPU is not on the Support List:
    http://www.asrock.com/mb/Intel/P67%20Pro3/?cat=CPU
    What's the board's BIOS version (it should be on a board sticker)?
  5. The CPU is on the support list 16th from the bottom. I'm not sure of the BIOS version because it didn't ship with a sticker (still not sure why). I got it new in an RMA a few months ago, so I would assume that it would be current. My old board also gave me a code 19 error with a fully updated BIOS chip, so I'm not sure whether it's the BIOS or the CPU.
  6. I see. It's 630, not 360 as in your first post (therefore the confusion).
    So, you've replaced the BIOS chip?
  7. I sent the entire board back to be RMA'd and they sent me a new one, BIOS chip and all.

    Fixed the typo in the original post. Sorry about that.
  8. It's a CPU related issue, in my opinion. Have you bought it from a retailer or ebay?
    Now I see that it has been used (1st post). Is it ES?
  9. I bought the CPU off of ebay.
    Quote:
    Is it ES?

    I don't know. How could I tell?
  10. Intel Confidential printed on it.
  11. There is not.
  12. Then it might be a faulty CPU. I would test it at a local shop, just to make sure it does work.
Ask a new question

Read More

RAM ASrock CPUs Motherboards