Sign in with
Sign up | Sign in
Your question

Pc starts but wont boot up (no beep, no POST, All components are working)

Last response: in Systems
Share
April 2, 2013 11:12:07 PM

Earlier I'm playing league of legends. I accidentally kick my CPU Case and it freezes so I restarted it. First it powered on but there is no logo of the asus mobo. All of the components are working esp. the cpu, HDD, ram, all the fans, and the power supply. The monitor says "no signal" so I restarted it but nothing happened. I've reset the CMOS, change the slot of RAM. And I've noticed that there is no beep at all. Please Help! Thanks!!

More about : starts wont boot beep post components working

a b C Monitor
a b à CPUs
April 2, 2013 11:13:43 PM

This may be a dumb question... BUT, did you check the video cable connection?
m
0
l
April 2, 2013 11:18:49 PM

The video cable is inserted into my cpu.
m
0
l
Related resources
a b C Monitor
a b à CPUs
April 2, 2013 11:21:23 PM

Your CPU?, I'm sorry, people saying things like that bothers me, all I can say is check that you knocked nothing loose and MAYBE if you kicked it hard enough or just are on a bad luck streak then it could be your hard drive. Good luck.
m
0
l
April 2, 2013 11:33:09 PM

The HDD is working fine. I've noticed that after I accidentally kick it the the display on them monitor becomes crazy I mean the display became chaotic so I restarted it.
m
0
l
a b C Monitor
a b à CPUs
April 2, 2013 11:35:24 PM

Do you have a Graphics card? Or integrated graphics?
m
0
l
April 2, 2013 11:36:44 PM

just integrated graphics.
m
0
l
a b C Monitor
a b à CPUs
April 2, 2013 11:40:02 PM

Make sure everything is properly seated, CPU, all cables, etc. You probably knocked something loose
m
0
l
April 2, 2013 11:41:16 PM

Yup. I have checked all the cable especially the CPU and the ram, HDD but nothing happens.
m
0
l
a b C Monitor
a b à CPUs
April 2, 2013 11:42:28 PM

Try taking everything out and then putting it all back in, including the CPU, you will probably need new thermal paste if you don't have any.
m
0
l
April 2, 2013 11:44:04 PM

Ok thanks for the help! I will just notify you if the problem persist :) 
m
0
l
!