Sign in with
Sign up | Sign in
Your question

GA-Z77x-UP5-TH Mother Board Wont Post Please Help

Last response: in Motherboards
Share
April 3, 2013 7:35:35 AM

Hey

So i have been having alot of problems with this build. I have a
GA-Z77x-UP5-TH and it will not post. I originally had the first mother
board and it wont work at all. So i took it back to canada computers
and they said that it was a factory short. So they gave me a brand new
one and i did an ouot of case build just too see if the motherboard
will respond this time and it did. So i put the mother board in the
case and i plug in the 8 and 24 pin power cables, the front panel
connectors and a monitor into the VGA port. I hit the power button and
the cpu fan starts to spin, but absolutly no display, no post beep,
only the LED lightens up and the cpu fan spins. I have no clue,out of
all the computers i have built for people, the only time i try and
build myself a gaming rig if fails.

- Rosewill Black Hawk full tower Case
- GA-Z77x-UP5-TH
- One Stick of Patriot 8Gb DDR3 1600Mhz ram
- Corsair CX750m PSU
- 8Tb Storage ( Never been connected to Mother Board)
- i7 3770k CPU
- BD
- DVD

Can anyone please help me :) 
March 18, 2014 8:36:49 PM

OMG this is soooo old lol, I remeber this... i took the memory module back and they tested it and it was DOA LOL. I have recently upgraded that pc into a water build,. Fantastic speeds, great stability!
m
0
l
a c 101 V Motherboard
March 19, 2014 4:38:59 AM

Glad everything is working out!
m
0
l
!