Sign in with
Sign up | Sign in
Your question

New CPU heatsink, no display?

Last response: in Graphics & Displays
Share
April 4, 2013 1:43:43 AM

Hello all, today i recieved a new heatsink (Hyper Cooler Evo 212) and when i finished installing it i tured the power on everything looked normal, all the fans started spinning all the LED's lighting up but my monitor dosent turn on like it does when i normaly turned my pc on. i didnt do anything but install the backplate and the cpu cooler (+ heatsink etc) i raelly dont know what to do if think you have any answer to my problem please dont hesitate to ask. i really dont know what when wrong i didnt unplug anything and everything is in its right place, iv checked the vga cord and tested it on 2 monitors.

More about : cpu heatsink display

a b à CPUs
April 4, 2013 2:02:08 AM

Check ram are correct in place - check gfx are correct in place - check psu and cables - maybe reset bios.
m
0
l
April 4, 2013 2:11:04 AM

correon said:
Check ram are correct in place - check gfx are correct in place - check psu and cables - maybe reset bios.


done all that, but still no luck i read somewere saying the backplate can cause the mobo to 'short out' any ideas?
m
0
l
Related resources
April 4, 2013 2:11:06 AM

correon said:
Check ram are correct in place - check gfx are correct in place - check psu and cables - maybe reset bios.


done all that, but still no luck i read somewere saying the backplate can cause the mobo to 'short out' any ideas?
m
0
l
a b à CPUs
April 4, 2013 2:27:58 AM

ye maybe try install old cooler again to check for short circuit...
m
0
l
!