Sign in with
Sign up | Sign in
Your question

USB 3.0 Ports not working on a new build with Windows 8

Last response: in Windows 8
Share
April 4, 2013 9:29:29 AM

I recently built a PC and everything is working great with one exception, none of my USB 3.0 ports work. My USB 2.0 ports all work just fine, but none of my four 3.0 ports work. I've tried plugging in both 2.0 and 3.0 devices to the 3.0 ports but they do not show up in Windows explorer or the device manager. I connected a WD 3.0 external hard drive to a 3.0 port and the LED on it lit up, but it wasn't recognized. Is this a driver issue? I uninstalled the Intel USB 3.0 host controller driver as Windows 8 is supposed to have native support for USB 3.0, but my devices are not working in the 3.0 ports. Can anyone help with this?

PC Info:
i5 3570k cpu
MSI Z77A-GD65 mobo
Windows 8 64 bit
April 4, 2013 1:29:28 PM

dextermat said:
go to msi website and download drivers:

do you have a yellow question mark device in device manager.

http://www.msi.com/product/mb/Z77A-GD65.html#/?div=Driver&os=Win8%2064

their are no usb driver so it might be the chipset one.

If it still doesn't work go see on WD website for a driver for windows 8


I've already downloaded all the driver's from the MSI website, maybe I need to uninstall and download them again?

I do have an unknown device showing up in the device manager (not in the USB tree though, this is listed as an unknown device) but this has been showing up regardless of whether I have anything plugged into a 3.0 port or not, which is another issue I need to get sorted out.

I checked the WD website and it looks like the only available downloads they have for mine are firmware updates. I did come across this on their website though:

External Drives:
If the drive not being recognized is a WD external hard drive, it can be caused by one of the following problems:
1. The driver being used may be corrupted. The symptoms of this problem can vary - The majority of the time however, the drive may request a driver, or will not appear as a connected device. Contact Microsoft or the System Manufacturer for assistance in resolving this issue, as we are unable to provide assistance in diagnosing the OS


Even if the firmware update did work on the WD drive what about my other USB 2.0 devices (Nexus 4, iPod, seagate external HDD among others) that I wanted to use on a 3.0 port? I know that, while I wouldn't be getting the transfer speeds of 3.0, USB 3.0 is backwards compatible with 2.0. My case only has 3.0 ports on the front so i'd rather have those working than going around the back all the time looking for my 1 remaining 2.0 port to plug a device into. Not to mention everything in this build is brand new so I want it to be working since I spent the money on it.





m
0
l
!