Sign in with
Sign up | Sign in
Your question

ATI Radeon HD 5570 Driver Crash; Reboot-Loop

Last response: in Graphics & Displays
Share
April 4, 2013 6:48:52 PM

No matter what driver I seem to use, whether it's installed by ATI's Catalyst software, directly from .inf file, or by other means, I just can't get them to work.

The moment the drivers install (via Catalyst or other executable) my system forces a reboot. I get to the "loading Windows" screen, and then.. it reboots again- it's a continuous loop until I boot into safe mode and remove said drivers. Same thing happens by other installation methods, only with those, I'm the one who initiates the first reboot. In some cases, it doesn't even reboot- it just shuts the system down completely.

I've had the same issue with both XP and Win7.

I've tried drivers supplied by AMD, by Windows Update, old drivers from various websites around the 'net, even going far as to try every ATI Catalyst suite since version 9, and no no avail. It's been almost five days of constant Google searches, forum skimming, and trial & error.

I know the card itself works just fine, as I'm normally a native Linux user, and everything (including full 3D rendering) works fine and dandy. I keep Windows on a dual boot to (hopefully) play games and for programs that require too many system resources to be used with a virtual machine or emulator. There was a time when it worked, but that was a while and many re-installations of OSes ago.

Can someone please help me before I go utterly bonkers? :) 

----------------------------

Hardware:
AMD Phenom II X4 945 cpu
Gigabyte GA-870A-UD3 mobo
ATI Radeon HD 5570 1GB DDR3 16X PCIe graphics card
4 GB Corsair Dominator DDR3/1333MHz mem
April 4, 2013 6:57:21 PM

Did you look at the event viewer details on the crash?
April 4, 2013 8:01:47 PM

bak0n said:
Did you look at the event viewer details on the crash?


I hadn't before, but I did just now. The only error(s) pertaining to the graphics card was (and there are a slew of the same):

  1. Error 4/3/2013 5:08:42 PM amdkmdag 6145 POWERPLAY


With a description of: System shutdown due to graphics card overheating
!