Solved

Can you change master/slave in BIOS? I removed a drive, now I cant boot anymore to my second drive.

Hello,

My comp has three hard disks: An Intel X25M SSD, a Seagate HD and a Samsung 840 SSD. Originally I had just the X25 and had a Win 7 installation on it. I upgraded to the Samsung and had an installation there as well and on boot, Windows let me choose which operating system.

I just sold my X25M and simply unplugged it. Now I cannot boot. In the bios it says the Seagate is the master and the SSD is the slave. Is there any way to change this?

I see the pins on the Seagate to specify master slave but the SSD doesnt appear to have any. If I unplug the Seagate and leave only the SSD, the system keeps asking to boot to CD. It's like the OS on the SSD doesnt exist. How can I get the comp to boot into the SSD like I was doing before now that the old SSD is gone?

Does it have something to do with the fact that the IntelX25M was the first disk to have an OS installed on it on this PC? Was there a boot record on there or something? I've verified all connections.

Motherboard is GIGABYTE GA-P67X-UD3-B3
3 answers Last reply Best Answer
More about change master slave bios removed drive boot anymore drive
  1. Best answer
    this might help
    http://support.microsoft.com/kb/927392

    and you should be able to set the boot seq on the bios to ssd first.
  2. Windows 7 stores it's boot files on a utility partition at the front of the drive. What seems to have happened is that when you installed a second copy on the Samsung SSD the installer retained the boot files on the Intel SSD. That is, the boot files for both installations were on the Intel SSD.
  3. Thank you very much. As it seems many people have problems using Bootrec.exe to fix a missing MBR, this thread is helping me immensely. I'm still searching for the solution as I cannot get Recovery to display my Windows installation yet.

    http://social.technet.microsoft.com/Forums/en-US/w7itproinstall/thread/7791044e-db7f-4144-a96c-945299811f58/

    What I tried: Using recovery manager to boot into cmd promt:


    Diskpart

    LIST DISK
    SELECT DISK (followed by the number of the disk . most likely 0)
    LIST PARTITION
    SELECT PARTITION (followed by your partition number. most likely 0)
    ACTIVE
    EXIT

    Still cant seem to get it to work. Will try Gparted and then swapping sata cables next.

    Finally got it working! Wasn't working for me initially because of my additional seagate drive I think. Once I removed it and had just my Samsung SSD, the instructions above combined with the Win repair tool worked and my installation was showing up.
Ask a new question

Read More

SSD Boot Seagate Storage