Sign in with
Sign up | Sign in
Your question
Solved

3 monitors, Radeon HD 6850, DVI+HDMI+DP. HDMI not working

Last response: in Graphics & Displays
Share
April 5, 2013 6:17:19 PM

I have 3 monitors, (2x 23" ASUS and 1x 24" acer) Yesterday I hooked them up to my Radeon HD 6850 using DVI, DVI, and then HDMI for the 3rd. It did not work, so I read around online and saw that getting a DP>DVI adapter might help, so I bought one.

Now, I have DVI(Working)+DP(working using adapter)+HDMI. The HDMI connected monitor just says cable not detected. If I open my display settings in Windows it sees the monitor, but if I attempt to extend the desktop it will not save the settings. If I try this in the Catalyst control center itself, the result is the same (well, it says one must be disabled, which is basically the same).

I can swap monitors and cables and the result is always the same that one will not work and I cannot extend the desktop. When rebooting, oddly, the two monitors it displays info on are the HDMI and DP monitors. Once it gets to Windows, it goes back to DP and DVI and HDMI returns to it's cable not connected message.

Oh and before I try to extend to the 3rd monitor in display settings it's set to "Disconnect this display" in windows. That's the option I change to extend, but it won't save.

Best solution

a b C Monitor
April 5, 2013 6:30:21 PM

I thought I remember reading somewhere you need an active adapter, is yours an active adapater?
Share
April 5, 2013 7:39:42 PM

Oh jeez. I feel retarded. I bought B087B-005B off the list at: http://support.amd.com/us/eyefinity/Pages/eyefinity-don...


But I bought one from the passive list without reading. Thanks for the response. I'll have to try the active one. (face palming so hard right now, I didn't even bat and eye because the thing had an eyefinity sticker on it when I was looking at Frys *sigh*)

Sorry everyone, I'm retarded.
m
0
l
April 6, 2013 3:06:46 PM

getochkn said:
I thought I remember reading somewhere you need an active adapter, is yours an active adapater?


That was it. Switched to an active adapter and it worked. Thank you.
m
0
l
Related resources
!