Sign in with
Sign up | Sign in
Your question

Turtle Beach X12 problems

Last response: in Home Audio
Share
April 11, 2013 1:03:44 AM

Hello everyone. I recently bought some X12s and straight away encountered problems that rendered them useless to me. I play World of Warcraft competitively therefore I need to be able to communicate with my team mates.

The thing with these headphones is that EVERY sound that comes from my pc is relayed through the microphone. For example... I'm playing music through the headphones, on team speak and someone speaks, I speak and it echoes it back through them till it reaches such a pitch that my ears almost bleed.

Literally every noise that is played through the headphones is relayed back through the mic for the world to hear. Now the only way I found to combat this is to use the "push to talk" function which is just terribly annoying and reduces my gameplay by a lot.

I have the all the leads plugged into the correct places but one thing I noticed is if I have them plugged into the front USB/Mic/Headphone port I get a lot of static and the echo is a lot worse. Also I did a test and when they are plugged in with no sound at all they are constantly bouncing around at about -20 -30 DB.

All help is appreciated.

If its worth while il make a video of this when I get back from work to show what I mean if you need additional information.

Thank you.

- Silus
April 11, 2013 9:36:46 PM

Is it only when you use vent/skype/teamspeak or all the time? Because it may be a setting in those. The headphones may also be turned up too high and the mic is picking up on that. To see if that's the problem, try turning up the minimum volume that the mic picks up sound.
m
0
l
April 15, 2013 11:22:02 PM

ewok93 said:
Is it only when you use vent/skype/teamspeak or all the time? Because it may be a setting in those. The headphones may also be turned up too high and the mic is picking up on that. To see if that's the problem, try turning up the minimum volume that the mic picks up sound.


I just tested it and its only on teamspeak it does this. Vent and Skype are fine.
m
0
l
April 16, 2013 3:07:21 AM

Okay there should be a setting that plays sound from your own microphone through your speakers, try turning that off.
m
0
l
!