New card from China purported to be Nvidia Geforce 7600GT not recognized as such

I had an old card burn out, but tested a new PCI-e card so the slot is good. The replacement card came with drivers for the wrong cards and all winxp/2K, so none of them work. I downloaded geforce drivers, but they don't work either. The card is recognized generically as shown below. How can I find a driver to use the card?

Name Standard VGA Graphics Adapter
PNP Device ID PCI\VEN_10DE&DEV_039F&SUBSYS_00000000&REV_A1\4&7E682FB&0&0010
Adapter Type Not Available, (Standard display types) compatible
Adapter Description Standard VGA Graphics Adapter
Adapter RAM Not Available
Installed Drivers Not Available
Driver Version 6.1.7600.16385
INF File display.inf (vga section)
Color Planes Not Available
Color Table Entries Not Available
Resolution Not Available
Bits/Pixel Not Available
Memory Address 0xFD000000-0xFDFFFFFF
Memory Address 0xD0000000-0xDFFFFFFF
Memory Address 0xFC000000-0xFE9FFFFF
I/O Port 0x0000EC00-0x0000EC7F
I/O Port 0x000003B0-0x000003BB
I/O Port 0x000003C0-0x000003DF
Memory Address 0xA0000-0xBFFFF
Driver c:\windows\system32\drivers\vgapnp.sys (6.1.7600.16385, 25.50 KB (26,112 bytes), 7/13/2009 4:25 PM)

Other general build information

OS Name Microsoft Windows 7 Ultimate
Version 6.1.7601 Service Pack 1 Build 7601

System Type X86-based PC
Processor AMD Phenom(tm) II X4 965 Processor, 3400 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 1005, 8/24/2010
SMBIOS Version 2.6
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume5

Hardware Abstraction Layer Version = "6.1.7601.17514"

Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 3.12 GB
Available Physical Memory 1.43 GB
Total Virtual Memory 6.24 GB
Available Virtual Memory 4.71 GB
Page File Space 3.12 GB
Page File C:\pagefile.sys
2 answers Last reply
More about card china purported nvidia geforce 7600gt recognized
  1. I couldn't find any info about this card. There is no info about the chip even on the pci database: http://www.pcidatabase.com/vendor_details.php?id=606
  2. VEN_10DE = Nvidia

    Apparently the DEV_039F id = G73GL = Geforce ~7 series (https://forums.geforce.com/default/topic/510672/geforce-300-200-100-series/geforce-gt240/)

    You might have to mod the drivers to work (or force install, doubt it will work with newer Nvidia drivers)

    Your still using XP why?
Ask a new question

Read More

Geforce Nvidia Systems