Sign in with
Sign up | Sign in
Your question

Help! New HTPC build not showing any signs of life

Last response: in Systems
Share
April 19, 2013 3:20:28 AM

Hi all,

first time poster here who is officially out of ideas at this point. I tried to find a solution from existing threads but I didn't really find a solution from any of the threads.

I recently decided to build myself a new and cheap rig mainly for HTPC use and I have now run into a BIG problem.

The system simply refuses to show any signs of life.

Problem:

When I press the power-button on the case the power-switch LED light turns on briefly and the PSU fan manages nudge maybe an inch and then nothing happens. No POST, no UEFI, no nothing. This problem has existed from the very beginning so the setup hasn't yet been in a working state.

Actions so far:

At first I suspected the PSU was the culprit but I tested the setup with the PSU from my gaming rig with the exact same results so that wasn't it.

My suspicions then turned to the motherboard so I then breadboarded my way through every combination of components imaginable with whom the system should at least start up and POST. Once again, no luck. I also tried a CMOS reset with no luck. After this I decided to RMA the mobo. I finally got a new mobo and this is where things get interesting.

I breadboarded my way upwards from only the CPU, one stick of RAM connected and front panel USB2 and audio connectors connected and this, incredibly enough, worked. UEFI started up without a hitch and everything seemed to be working fine. Both sticks of RAM connected worked as well. I then proceeded to connect the HDD to the SATA connector and the USB3 front panel connector. At first I forgot to connect the power cable to the HDD but the system still started into UEFI with no problems. I then connected the HDD power cable, the SATA and power cable for the DVD-drive and front panel fan.

THEN, everything died on me again. The PSU fan occasionally tries to spin and the power switch LED blinks briefly but once again, no POST, no UEFI, no nothing. Once again, the same results, with the other, proven, PSU.

I have once again tested the setup both inside and outside the case with all combinations of components imaginable with no luck at all. The CPU and socket pins are also ok together with the cooler and thermal paste. I have also tried to jump-start the motherboard from the motherboard connectors with no luck. The system stays dead. The mobo has no LEDs on it so troubleshooting this way is not an option in this case. I have, at least in my own opinion, also ruled out any visible risks for shorts inside the case.

-Is there anything more I can do at this point?
-Can the HDD or DVD drive short or lock the mobo once power goes through them?
-I'm also a total noob when it comes to the inner workings of UEFI so is there something I could have missed here in terms of startup sequence?
-Should I just go and buy a new mobo at this point?

The setup is as follows:
AsRock H77M-ITX
i3-3225 with Phanteks PH-TC90LS cooler
Kingston HyperX Genesis 2x4GB
WD Caviar Green 500GB
Corsair CX430W
Cooler Master Elite 120 Advanced
Phanteks PH-TC90LS
+a passive Asus GT610 I haven't tried to connect yet.
Some ASUS DVD/RW drive

Any suggestions and ideas would be very much appreciated at this point as I'm slowly starting to lose my sanity with this one!
April 20, 2013 4:42:32 AM

I suspect you may have some extra screw ports under your motherboard (the things you screw into your case to screw your motherboard into) The next would be a bad psu which does happen just because you are getting juice does not mean its enough juice to run every thing. So i would try to trouble shoot these 2 things first and see how it goes. I also had a problem where my keyboard on my system while plugged in would not let my system boot for what ever reason. so you may want to try it without a mouse and keyboard as well for at least sanitys sake.
m
0
l
!