Solved

Very low write speeds from Crucial SSD

I built my system a few years ago and in January I bought a new GPU and SSD. My GPU seems to have no issues, but since Day 1 I have suffered extremely low Write Speeds from my SSD. I didn't realize what was the cause and for a logn time i've just been dealing with it. The fact of the matter is I can't stand that my desktop is slower than my lapto so I'm finally trying to figure out what went wrong.

Some Problems:
- I messed with a bunch of settings when I first bought the SSD. Guides that tell you things you're supposed to do with a new SSD and similar articles.
- It was 3 months ago and I've forgotten everything I did and what articles I followed.
- Not sure if I even correctly did some of the stuff listed on the many webpages I visited and my tinkering could very well be the only real problem here.
- SSD didn't come with a mounting thing so I just duck taped it to the case.

Now here is the technical stuff with newegg item codes:

Computer

Antec Three Hundred Black Steel ATX Mid Tower Computer Case
Item#: N82E16811129042

PSU CORSAIR|850W CMPSU-850TXV2 R
Item#: N82E16817139022

CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800)
Item#: N82E16820145345

Seagate Barracuda 7200.12 ST31000524AS 1 TB 3.5" Internal Hard Drive
Not from newegg

PNY VCGGTX680XPB-S GeForce GTX 680 2GB 256-bit GDDR5 PCI Express 3.0 x16 HDCP Ready SLI Support Video Card
Item#: N82E16814133469

COOLER MASTER Hyper 212 Plus Intel Core i5 & Intel Core i7 compatible RR-B10-212P-G1 120mm
Item #: N82E16835103065

ASUS M4A89GTD PRO/USB3 AM3 AMD 890GX SATA 6Gb/s USB 3.0 HDMI ATX AMD Motherboard
Item #: N82E16813131631

AMD Phenom II X4 955 Black Edition Deneb 3.2GHz Socket AM3 125W Quad-Core Processor HDZ955FBGMBOX
Item #: N82E16819103808

SAMSUNG DVD Burner Black SATA Model SH-S223L LightScribe Support - OEM
Item #: N82E16827151188

Crucial V4 CT256V4SSD2 2.5" 256GB SATA II MLC Internal Solid State Drive (SSD) SSD Only
Item#: N82E16820148588

Here's a picture of the Read / Write Test -


Thank you for your time!
22 answers Last reply Best Answer
More about low write speeds crucial ssd
  1. well for one thing it says pciide bad in red letters

    should say something like storahci good or storahci ok

    so guessing you didnt set it to ahci in the bios

    also try a different benchmark like atto

    my mushkin ssd scores low--though nowhere near as low as that in as ssd

    but scores fine in atto--something to do with compressible/non compressible data i think
  2. Before you change in the BIOS, see here for registry key change you have to make first:
    http://forums.guru3d.com/showthread.php?t=313676
  3. I followed your post's instructions J_E_D and then I set the SATA ports to AHCI in BIOS. Rebooted and got an error message "Reboot and select proper boot device or Insert Boot Media in selected Boot Device and press a key" Any suggestions?
  4. On the Boot section of my bios it says:
    1st boot device [Removeable Dev.]
    2nd boot device [IDE:V4-CT256V4SSD2]
    3rd boot device [ATAPI CD-ROM]
    4th boot device [IDE: TSSTcorp CDDVD]
  5. change removable dev to 4th place
  6. Same message. I'm gonna switch 2nd boot device [IDE:V4-CT256V4SSD2] to #1 spot.

    Okay now it's in this order:
    1st boot device [IDE:V4-CT256V4SSD2]
    2nd boot device [IDE: TSSTcorp CDDVD]
    3rd boot device [ATAPI CD-ROM]
    4th boot device [Removeable Dev.]

    and I've tried it where TSSTcorp is first and V4 is second as well, each option has given me the same error as above.
  7. Further down in that forum I linked it has a couple of tips (keep reading):
    http://forums.guru3d.com/showthread.php?t=313676&page=3
    - Is the SSD plugged into SATAIII's "0"port (may have to see your mobo manual for the recommended port)?

    Edit: Since it says IDE before the SSD name I'd think there is still some setting in the BIOS that thinks is IDE instead of AHCI.
  8. there may be more than one sata controller on your motherboard

    mine has 3 different ones

    so the one your ssd is on needs to be ahci

    i always connect my ssds to the intel ports if the motherboard has them
  9. So I'm checking the Storage Configuartion option of the BIOS and it says
    SATA Port1 - Port4 [ AHCI]
    SATA Port5 - Port 6 [AHCI]
    This is the only option I can find that mentions IDE and AHCI.
  10. just looked

    looks like your board has all the sata controllers on the south bridge

    but check in the integrated peripherals section of the bios anyway

    hope you didnt have anything important on the drive as editing the registry can be risky
  11. BIOS>Advanced>
    COU COnfig - nothing
    Chipset - Nothing
    Onboard Device config - Nothing
    USB config - Nothing
    PCIPnP - Nothing
    I'm not sure what you mean by integrated peripherals. Anything on my SSD can be replaced I keep all my stuff on my hdd that's setup with it.
  12. there may not be an integrated peripherals in your bios

    it may be in the chipset section--not every bios is the same

    will it boot if you set it back to ide?
  13. Boots up as normal when changed back to IDE
  14. thats good then

    try atto benchmark just out of interest

    then its a case of more registry editing or set bios to ahci and reinstall windows
  15. Here's the atto results:

  16. certainly better than as ssd

    as ssd uses incompressible data so the crucial drive may not like that

    but should be higher in atto

    its a sata 2 drive so something like 260mbs and 240mbs read and write maximum i think
  17. What does that mean? I have SATA 2 I think, so does that mean i am almost 200 mbs off of the max write speed?
  18. not 200mbs off the max

    in atto you scored 194518 and 229923 at the highest point
    out of a rough max of 240000 and 260000

    so roughly 45mbs and 30mbs of max if its a sata 2 drive

    some pretty poor reviews here of it

    http://www.newegg.com/Product/Product.aspx?Item=N82E16820148588

    did you check for any firmware updates?

    and it should improve if you get it into ahci
  19. Do you have any suggestions to get it into ahci? I can't think of anything I would do differently than last time I tried? Also what do you mean by firmware updates? I run windows update, but that's it I think.
  20. Best answer
    just found a website that lists its specs

    and they are listing it at 230mbs and 190mbs

    which is basically what you got in atto

    they are also not giving it very good reviews

    http://www.overclockers.co.uk/showproduct.php?prodid=HD-021-CR&tool=3

    a firmware update is a little like a driver update--but only comes from the drive maker

    usually to fix an issue or make it faster

    BUT unlike a driver update a firmware update is written to the hardware --NOT to windows

    similar to a bios update--you MUST get the firmware exactly meant for your drive

    as for ahci i would just set it in the bios and reinstall windows--probably quicker than all the hassle of trying to

    edit the registry etc
  21. How would I reinstall windows? set it to ahci and then put in the disk and boot like that?
  22. yes

    heres the firmware page if you want to try it 1st

    http://www.crucial.com/uk/support/firmware.aspx?source=web

    this may wipe the drive anyway

    my intel ssd and mushkin ssd and samsung dont wipe the drive updating the firmware but dont know about

    crucial--my ssds give a warning saying back up your data just in case but i have updated them all with no data

    loss
Ask a new question

Read More

SSD Crucial GPUs Storage