Sign in with
Sign up | Sign in
Your question
Solved

Gigabyte 7950 loses display and artifacts on reboot

Tags:
  • Gigabyte
  • Build
  • Graphics
  • Graphics Cards
  • Radeon
  • Displays
Last response: in Graphics & Displays
Share
April 20, 2013 1:17:00 PM

Hey everyone! This is my first time posting so just let me know if you need anymore information.

I just built my first build yesterday. After installing everything and updating my drivers I thought I was good to go. But I noticed that randomly, I would lose signal to my TV (unable to test the DVI port as I currently do not have a monitor). I thought it might have been the TV or HDMI cord I was using so I switched TVs and cords. Still happened randomly.

So I am assuming it is a graphics card problem. I checked and made sure it's drivers were up to date, flashed my bios, checked for any visual damage and reseated the card into the PCI-e 3.0 slot it was in. Still to no avail.

I tried starting up a game (Firefall) and the display went out instantly after launch.

My computer continues to run just fine. It's just the display that turns off. Sometimes it just shows a black screen, while other times it displays the "No Signal" message. When I eventually have to reboot, (this is what scared me the most) I sometimes get two artifact lines during start up and the entire screen artifacted when it should be displaying my Win8 login screen. This all clears up when I do another reboot.

Any idea what could be going on? I would really hate to find out that I bought a faulty GPU and have to return it already. But if that's what I have to do, I'd rather it be that than buying a new card or just dealing with this problem.

Thanks for your time!



Here is my part list if you need it:

PCPartPicker part list: http://pcpartpicker.com/p/QcQO
Benchmarks: http://pcpartpicker.com/p/QcQO/benchmarks/

CPU: Intel Core i5-3470 3.2GHz Quad-Core Processor
Motherboard: ASRock H77 Pro4/MVP ATX LGA1155 Motherboard
Memory: Corsair Vengeance 8GB (2 x 4GB) DDR3-1600 Memory
Storage: Seagate Barracuda 2TB 3.5" 7200RPM Internal Hard Drive
Video Card: Gigabyte Radeon HD 7950 3GB Video Card
Case: Apevia X-Plorer2 Black/Blue ATX Mid Tower Case
Power Supply: Cooler Master eXtreme Power 550W ATX12V Power Supply
Operating System: Microsoft Windows 8 Full (64-bit)

More about : gigabyte 7950 loses display artifacts reboot

a b U Graphics card
April 20, 2013 1:53:40 PM

Sounds like a bad GPU, did you get it through newegg?

It could also be that PSU.
m
0
l
April 20, 2013 2:05:43 PM

lycros said:
Sounds like a bad GPU, did you get it through newegg?

It could also be that PSU.


I got it through Amazon. And what could be wrong with the PSU? Wattage too low?
m
0
l
Related resources
a b U Graphics card
April 20, 2013 2:12:12 PM

Well the PSU you have isn't of the best quality. It SHOULD work. But for example a 550W PSU from seasonic http://www.newegg.com/Product/Product.aspx?Item=N82E168... has a single +12V rail with 45A for a total power output of 540W. That Coolermaster has 2 +12V (16A each) for a total of 32A/384W.
m
0
l
April 20, 2013 2:18:29 PM

lycros said:
Well the PSU you have isn't of the best quality. It SHOULD work. But for example a 550W PSU from seasonic http://www.newegg.com/Product/Product.aspx?Item=N82E168... has a single +12V rail with 45A for a total power output of 540W. That Coolermaster has 2 +12V (16A each) for a total of 32A/384W.


So let me see if I understand. My PSU is subquality so it's outputing less watts than advertised (384W vs 550W)? Should I replace it?
m
0
l

Best solution

a b U Graphics card
April 20, 2013 2:27:58 PM

Well in order to call it a 550W PSU the other rails have very high amps while the +12V rail is subpar. The problem is that your system isn't going to need that much power from the other rails, the +12V rail is where your highest power consuming parts are getting it's power from (CPU, MB, GPU, etc) that's why the +12V rail is considered the most important.

If I were you I would return both the PSU and the GPU. Get a different PSU and just get a replacement of the GPU.
Share
a b U Graphics card
April 20, 2013 2:37:50 PM

Check out CX500 and CX600 for $49.99 and $64.99, respectively, at both newegg and amazon for the same price. Although amazon doesn't seem to have the rebate for the 600W.
m
0
l
April 20, 2013 2:38:07 PM

lycros said:
Well in order to call it a 550W PSU the other rails have very high amps while the +12V rail is subpar. The problem is that your system is going to need that much power from the other rails, the +12V rail is where your highest power consuming parts or getting it's power from (CPU, MB, GPU, etc) that's why the +12V rail is considered the most important.

If I were you I would return both the PSU and the GPU. Get a different PSU and just get a replacement of the GPU.


Thanks! That was very informative. I will return the parts tomorrow. Hopefully this helps. If not, you might be seeing more of me haha
m
0
l
April 21, 2013 8:31:51 PM

lycros said:
Well in order to call it a 550W PSU the other rails have very high amps while the +12V rail is subpar. The problem is that your system isn't going to need that much power from the other rails, the +12V rail is where your highest power consuming parts are getting it's power from (CPU, MB, GPU, etc) that's why the +12V rail is considered the most important.

If I were you I would return both the PSU and the GPU. Get a different PSU and just get a replacement of the GPU.


lycros said:
Check out CX500 and CX600 for $49.99 and $64.99, respectively, at both newegg and amazon for the same price. Although amazon doesn't seem to have the rebate for the 600W.


I figured it out! I hesitantly decided to give the Catalyst 13.3 Beta drivers a go and what do you know? It worked! PC has been running for 8 hours now with no loss of display even when playing graphical intensive games such as Crysis 3. I will give it a couple days just to see if the problem reoccurs but as for right now, it is working at full capacity!

Thanks for all your help!
m
0
l
a b U Graphics card
April 21, 2013 8:49:32 PM

That's awesome! Seems strange that updating to 13.3 beta drivers would solve a problem like that. What version of the driver were you using before?
m
0
l
April 22, 2013 2:49:38 AM

lycros said:
That's awesome! Seems strange that updating to 13.3 beta drivers would solve a problem like that. What version of the driver were you using before?


I believe it was the 13.1 version. I'm still not sure if this was a complete fix as it loss display (and sound?) while playing Firefall. But after a reboot it did not have another incident for the following 6 hours. Not sure if the beta drivers just helped or if this is all just a coincidence. Either way, I'd rather have it crash once a day than every time I try to play a game. At least until I can afford a better PSU and can send in my GPU.
m
0
l
a b U Graphics card
April 22, 2013 8:04:19 PM

If you're still under the return period from where you bought it, I recommend just returning those parts now. It'll save you headache, heartache, money and time in the long run.
m
0
l
April 27, 2013 12:04:42 PM

lycros said:
If you're still under the return period from where you bought it, I recommend just returning those parts now. It'll save you headache, heartache, money and time in the long run.


Ok, so I returned the PSU and purchased a Seasonic M12II 620W PSU that had a higher wattage and amperage than my previous PSU. Still loses display...

I guess my last option (That I was hoping I wouldn't have to do) would be to rma the GPU. Do you have any idea how long it would take to receive the new one?
m
0
l
a b U Graphics card
April 27, 2013 1:14:30 PM

That's a great PSU! Would you be sending the RMA through the merchant or manufacturer?
m
0
l
April 27, 2013 2:02:47 PM

lycros said:
That's a great PSU! Would you be sending the RMA through the merchant or manufacturer?


Thanks! And I just finishing contacting Amazon Support and they are sending me a replacement model that should be here by Wednesday on the 1st of May. Hopefully the replacement doesn't fail as well.
m
0
l
a b U Graphics card
April 27, 2013 4:42:50 PM

That's great news that you were able to RMA through Amazon! I hope so too that your replacement is perfectly fine.

I just recently dealt with an RMA through Sapphire and based on that experience I'll probably avoid their products, which is a shame because I like their cooling solutions. But the first replacement they sent me was physically defective (damaged pcb, warped pcb, warped pci bracket) the second replacement I received had a bent pci bracket, but I was able to bend it back. At this point it had been nearly a month and I didn't want to wait any longer.
m
0
l
April 28, 2013 1:53:29 AM

lycros said:
That's great news that you were able to RMA through Amazon! I hope so too that your replacement is perfectly fine.

I just recently dealt with an RMA through Sapphire and based on that experience I'll probably avoid their products, which is a shame because I like their cooling solutions. But the first replacement they sent me was physically defective (damaged pcb, warped pcb, warped pci bracket) the second replacement I received had a bent pci bracket, but I was able to bend it back. At this point it had been nearly a month and I didn't want to wait any longer.


Ah, sorry to hear about your troubles. Thanks for the insight on Sapphire's customer service and RMA reliability. I'll see if Amazon will pull through with the first RMA. Did you have to do anything special to replace the replacement? How many times do they usually allow for you to RMA a specific product?
m
0
l
a b U Graphics card
April 28, 2013 9:40:35 AM

Sapphire uses a third party RMA company called Althon Micro, Inc. Sapphire support wasn't very helpful during the process. I had to send them pictures of the damaged card and wait a few days for them to approve another RMA. They gave me a shipping label to return the replacement, but didn't want to cross ship. They should allow you to RMA as long as you're in warranty. The RMA company gives you 30 days or continues your original warranty (which ever is longer).

I've RMA'd through newegg and Amazon and would MUCH rather do that.
m
0
l
!