Sign in with
Sign up | Sign in
Your question
Solved

i7 3770k performance not upto the mark! :(

Last response: in CPUs
Share
April 26, 2013 9:26:40 AM

Greetings all,

I am currently facing a major problem with my 3770k bought yesterday. The issue is with the performance, I installed out of the box with no OC at defaults settings and ran a CINEBENCH CPU test. I got a score of 5.45 which I believe is way too less compared to what I should be getting that is around 7.0. My 2600k at default which is degrading after I OC'd to 5.0ghz for more than a year gave me a 6.5 result at stock frequency value. I ran the intel diagnostic tool and 3770k PASSED!

One important note is about my motherboard and my PSU. I believe any of the two could be the culprit but I need your advice... Using a Gigabyte Z68X-UD3H-B3 flashed UEFI which I know Ivy wasn't compatible with F12 bios so had to update, and I am not sure if this bios is actually good enough for Ivy yet! Plus I am using a 600W Thermaltake TR2 PSU. Could it be the PSU? Do I need more supply?

I got this processor from NCIX and I spoke to them and they said research on your motherboard and PSU. You might need to upgrade any of the two. They may let me test but I will have to pay the restocking fee which I wanna avoid. Please help! I am looking for OC'ing it to 4.5 Ghz. I will appreciate all your answers! Thanks!

Update:
Also, my temps are low.. varies from 25 to 35 at idle and max to 54 at 100%.

Specs:
Motherboard: Gigabyte Z68X-UD3H-B3 rev1.3 (flashed uefi)
Graphic: GTX 560Ti
Ram: Mushkin 2x4 Gb 1600mhz
CPU: i7 3770k (At stock no OC yet)
PSU: Thermaltake 600W TR2
Heatsink: Noctua nh-d14

Best solution

April 26, 2013 11:01:52 AM
Share

make sure ur bios is up to dte thats really imortant
make sure in bios no cores r disabled
search on google unparkcpu it unparks all the cores which r parked and sometimes it helps and sometimes it doesnt
hope it helps if i find something else i will tell u :) 
April 26, 2013 11:54:33 AM

Ramzzz2936 said:
make sure ur bios is up to dte thats really imortant
make sure in bios no cores r disabled
search on google unparkcpu it unparks all the cores which r parked and sometimes it helps and sometimes it doesnt
hope it helps if i find something else i will tell u :) 


Hey, Thank you for the response! And a slap to myself on my face! :pfff:  Apparently, my CINEBENCH was set to use only 4 cores and not the threads. As a result, it gave me a lower score. I just changed that setting and the scored jumped to 7.56 ! But yea, I wouldn't have thought about it if your response was not on core specific! Thanks a lot !!
!