Sign in with
Sign up | Sign in
Your question

PC stuck at Starting Screen after Display Driver update

Tags:
  • Build
  • Graphics
  • Displays
Last response: in Graphics & Displays
Share
April 26, 2013 12:15:23 PM

I just received my first Vid card for my first build I put together Sept 2012. Up till now I have been using my integrated HD4000 graphics on my i5 3570k processor. I installed this video card today and it runs fine (seemingly) until I update the driver. I have tried the disc that comes with it, MSI's website and AMD's website. Everytime it has to restart the system for the driver update it gets stuck at starting windows screen. MSI's tech support did not seem very knowledgable when I spoke to them and finally just said I should RMA the card, any help would be much appreciated.

Build:
i5 3570k Vid Card MSI R7850 Twin Frozr 2GD5/OC Radeon
Asus p8z77-v LK
Gskill 4x4gb ram
Corsair HX series 750w 80 plus gold certified

More about : stuck starting screen display driver update

April 26, 2013 12:24:11 PM

coltrain63 said:
I just received my first Vid card for my first build I put together Sept 2012. Up till now I have been using my integrated HD4000 graphics on my i5 3570k processor. I installed this video card today and it runs fine (seemingly) until I update the driver. I have tried the disc that comes with it, MSI's website and AMD's website. Everytime it has to restart the system for the driver update it gets stuck at starting windows screen. MSI's tech support did not seem very knowledgable when I spoke to them and finally just said I should RMA the card, any help would be much appreciated.

Build:
i5 3570k Vid Card MSI R7850 Twin Frozr 2GD5/OC Radeon
Asus p8z77-v LK
Gskill 4x4gb ram
Corsair HX series 750w 80 plus gold certified


Hi
Try to uninstall the Intel VGA Drivers
You must have simple ATI drivers download and install
You may try clean OS install may be is you OS buggy ...
And OFC it may be an GPU RMA ....
m
0
l
April 26, 2013 12:40:54 PM

Nikolay Savov said:
coltrain63 said:
I just received my first Vid card for my first build I put together Sept 2012. Up till now I have been using my integrated HD4000 graphics on my i5 3570k processor. I installed this video card today and it runs fine (seemingly) until I update the driver. I have tried the disc that comes with it, MSI's website and AMD's website. Everytime it has to restart the system for the driver update it gets stuck at starting windows screen. MSI's tech support did not seem very knowledgable when I spoke to them and finally just said I should RMA the card, any help would be much appreciated.

Build:
i5 3570k Vid Card MSI R7850 Twin Frozr 2GD5/OC Radeon
Asus p8z77-v LK
Gskill 4x4gb ram
Corsair HX series 750w 80 plus gold certified


Hi
Try to uninstall the Intel VGA Drivers
You must have simple ATI drivers download and install
You may try clean OS install may be is you OS buggy ...
And OFC it may be an GPU RMA ....


Those intel graphics are integrated in the Processor so I don't believe it has drivers. I will try a clean OS install.
m
0
l
Related resources
April 26, 2013 2:43:15 PM

I reset my BIOS to factory defaults and deleted any previously downloaded driver updates I attempted. After doing this I tried again and PRESTO we are up and running. If anyone has this problem again and your using an asus motherboard with onboard overclocking options. I suggest resetting to factory defaults just in case
m
0
l
April 26, 2013 2:56:15 PM

coltrain63 said:
I reset my BIOS to factory defaults and deleted any previously downloaded driver updates I attempted. After doing this I tried again and PRESTO we are up and running. If anyone has this problem again and your using an asus motherboard with onboard overclocking options. I suggest resetting to factory defaults just in case


Good job :) 
I`m happy for ya !
m
0
l
April 26, 2013 2:59:53 PM

Hey, thank you for your help. It got me rolling on the right path and saved me an unnecessary RMA
m
0
l
!