Solved

Help! p8z77-v le plus

right so heres the problem my pc wont display anything after I updated the bios, now everything boots up no beeps no red lights nothing, it was working before that I've cleared the cmos, taken the battery out reseated everything, anyone have any ideas? thanks

specs

i5 3570k
4gb ram cant quite remember the name but its compatiable
2x asus hd 7770 xfire
corsair 800w psu gaming series
p8z77-v LE plus

also the cpu motherboard and psu are all new
10 answers Last reply Best Answer
More about p8z77
  1. try using the usb bios flashback to re-flash the bios
  2. mcnumpty23 said:
    try using the usb bios flashback to re-flash the bios


    Tried that but still no display so I would have no idea if it worked or not
  3. Hi, Have you used the flashback or EZ Flash in BIOS?
    If Flashback, have you renamed the file?
    Try again the flashback. Use a FAT formatted USB stick. Rename the downloaded, unzipped file.
    Connect the drive to the designated USB flashback port.
    Dont't start the board. Just make sure that the PSU is connected and turned on. Press the flashback button for 3 seconds.
  4. ok so now I have the red dram light which is confusing =/ try a different stick ?
  5. Leave single RAM module installed. See if still the same.
  6. hmm just put the one stick in still the same light problem if I hit the dram button the light goes but still no display should I try a earlier bios update?
  7. Yes. try a different version. See if still the same.
  8. still no display =/
  9. Best answer
    Remove the graphics card and use the onboard graphics.
  10. using the onboard graphics has shown me a display thank you so much for your help
Ask a new question

Read More

Motherboards