Sign in with
Sign up | Sign in
Your question

UEFI screen blank with ASUS HD7770 graphics card

Last response: in Motherboards
Share
April 30, 2013 9:33:05 PM

I have an ASUS desktop with AMD A8-5500 cpu (ASUS CM1745). Came with a cheap graphics card, and I replaced it with an ASUS HD7770 GPU. Running Windows8. HD7770 has only HDMI and DVI connectors. Two monitors set up: 1280x1028, and 1980x1080, both connected by DVI. Most everything runs fine, but when I go into advancd startup to enter UEFI (or any advanced startup feature, such as restoring a prior state), the screen goes blank. With the old GPU it worked, and that card had a VGA connector. The motherboard/processor itself has a GPU, with VGA and DVI connectors, but that seems to be disabled (cable in VGA never shows anything). Having read some of the threads here, the UEFI seems to require handshaking between GPU and monitor, and it appears to me it only works with VGA. HD7770 does not have VGA. Has anyone solved this problem?? Is there a way to activate the GPU built in to the AMD processor in these systems? One of the monitors is an ASUS unit, and I had assumed that could communicate with their graphics cards. So far no solution from ASUS.
Have updated bios to latest versions, for both the HD7770 and motherboard. The only way I access the UEFI is to swap the old GPU card back in.
thanks for any help,
Roger
a b Ĉ ASUS
a c 87 U Graphics card
a b V Motherboard
April 30, 2013 9:52:26 PM

When you have a graphics card installed, the motherboard video outs aren't going to work.

That being said, try entering UEFI with only a single monitor installed.

Also, what's your motherboard? That matters far more than anything else.
m
0
l
a b Ĉ ASUS
a b U Graphics card
a c 324 V Motherboard
April 30, 2013 10:04:43 PM

The recommended power supply for the HD 7770 is 500 watts. The ASUS CM1745 looks like it has only a 300 watt power supply. The video card may not have enough power to startup.
m
0
l
Related resources
a b Ĉ ASUS
a c 87 U Graphics card
a b V Motherboard
April 30, 2013 10:05:50 PM

Calvin, he gets into windows fine - I don't think that's the problem.
m
0
l
May 1, 2013 12:07:14 PM

I did upgrade the power supply to 550watts, swapping in the PS from an old XPpro system that died. I have also tried just one monitor (either), with either DVI or HDMI connections. The 1980x1080 monitor is a new ASUS unit, so I was suprised that didn't work. I will try taking out the video card altogether and see if the onboard GPU activates, and use the VGA connection. Not sure about the particular motherboard in the box... made by ASUS, but I will have to open the box again and look. I did post the question to the motherboard portion of this site, so a lapse on my part.
m
0
l
a b Ĉ ASUS
a c 87 U Graphics card
a b V Motherboard
May 1, 2013 1:45:37 PM

Certainly having no graphics card might help - the issue might be that your UEFI isn't booting with PCIe graphics. *(though you said the old card worked?)
m
0
l
May 1, 2013 7:17:30 PM

Motherboard is ASUS F2A85-M. Yes, the old card worked, which was an HD7470, a simple and slow PCIexpress graphics card with a VGA and HDMI connection. I don't know why they put this card in the system, as it is supposedly slower than the built in GPU in the AMD A8 processor.
m
0
l
a b Ĉ ASUS
a c 87 U Graphics card
a b V Motherboard
May 1, 2013 7:38:16 PM

Hmm...

And have you, by any chance, a way to test your 7770 is a friends' system?
m
0
l
May 1, 2013 8:29:48 PM

Problem solved!
I removed the HD7770 and hooked up a monitor to the VGA connector for the motherboard onboard graphics (Radeon HD7560). Was able to enter UEFI. CHecked the display settings, and the integrated graphics (IGFX) was set to "auto". I switched this to "force". Primary display by default is set to PCI. Then I put the HD7770 back in, hooked up the both monitors to DVI, and also kept one of them hooked up to motherboard GPU. Runs Win8 like before, and when rebooting to the EUFI, it communicates with the monitor through the VGA, and I can get into the bios. When running win8, iI use the "screen resolution" menu to disconnect the VGA display, and "extend" the DVI displays together.
For some reason, the UEFI insists on communicating via VGA.

thanks everyone for the help.
m
0
l
a b Ĉ ASUS
a c 87 U Graphics card
a b V Motherboard
May 1, 2013 8:34:10 PM

Ahh, I was wondering if it would be something like that.

Funny that it took such a bloody annoying workaround like that.
m
0
l
!