Sign in with
Sign up | Sign in
Your question

No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate

Tags:
  • Graphics
  • AMD
Last response: in Graphics & Displays
Share
May 1, 2013 3:01:30 AM

Hey all.. as the title says I am having this issue..

before I begin let me label my specs and information rq.

i5-3570k
7950
asrock extreme 4 z77
750w 80 bronze
sniper ram 8g

if u need any more info please let me know..

So it all started when i was playing a game.. the game froze after 10min.. had to hold down power button..

then in boot up windows went back to low resolution and then gave me the error message
"No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your amd hardware"

after countless attempts and research I have run out of ideas.

I have tried all different types of drivers. uninstalls of drivers.

clean install of os.

says my BIOS is up to date...

I have no idea what to do..

it did it again today after a fresh install but after windows automatically installed a video driver it re booted and here i am.. havent tried a game yet...

the thing is.. this has been happening since april 20th when i built this thing..

I have tried a different pci slot, made sure all connections were tight and right.

oddly enough.. since april 20th the machine would run a week or so with no issues.. untill one day booting up the system and it saying the error message.. Sometimes the game will freeze and other times when i boot up one day it will say it..

I am out of options and the only thing i can think of is to RMA this card.

Please help me out and at least determine it is infact my GPU so i can return it.. Thanks!

More about : amd graphics driver installed amd driver functioning properly install amd driver

May 1, 2013 6:21:54 AM

kinda sounds like a digital signature problem. have you tried using windows update to install the gpu drivers?

you could try disabling digital signatures (link). if this doesn't help, then RMA.

disabling digital signatures can cause troubles by allowing you to install bad drivers.
m
0
l
May 1, 2013 11:51:41 AM

funny, the SAME thing is happening with my Dell 3550 laptop :/  I've tried the drivers from Dells website and the drivers from AMDs...

tonight I think I'm gonna have to remove all the drivers and start over

Dry
m
0
l
Related resources
May 1, 2013 5:16:50 PM

Yeah i did disable digital signatures and it didnt work.
m
0
l
a c 180 À AMD
May 1, 2013 7:11:05 PM

Yes, from your description, it does sound like a defective card. If you did an O/S clean install and the problem re-occurred with the Windows/AMD driver, I would have to believe the card is the issue.
m
0
l
May 1, 2013 8:24:28 PM

yeah.. its working fine now but if it does it again im shipping back priority :p 
m
0
l
May 2, 2013 6:26:20 AM

I fixed my issues last night.

2 things:

1. Ran windows updates and made sure all my .NET framework stuffs were up to do date
2. AMD has a removal utility that actually did a real complete removal of ALL AMD related stuff.

This allowed me to do a clean install of the Dell ATI driver and now it works great.

but mind you, the AMD tool removes ALL AMD stuff, so if you are using an AMD chipset and / or an AMD APU, it will blow all those things up to.

Dry
m
0
l
May 2, 2013 7:21:05 AM

I think i fixed it aswell. but i wont know for sure for a week or so.. but I went to gigabyte's website (my cards manufacture) and it had a driver to download and i did that on top of my amd stuff and apparently everything works fine.. I also switched the PCI slot i was using
m
0
l
October 8, 2013 1:28:24 PM

Uninstall AMD Contol Center
m
0
l
June 7, 2014 11:17:50 PM

I am having Dell Inspiron 7520 with 2GB AMD Graphic card.

Downloading "Leshcat’s Catalyst 14.4 WHQL UnifL v1.3" worked for me.
m
0
l
!