Closed Solved

Android Driver Help!

Hi,
I recently bought a micromax A116 Android jellybean . I wanted to root the device.

When I connect the phone to my PC normally (with the battery) I face no issues. I can transfer stuff to my SD card etc. The issue is when I connect my phone without the battery , device manager on my PC shows an unknown device MT65xx preloader, but within seconds it disappears from device manager with the error "

Currently, this hardware device is not connected to the computer. (Code 45)
To fix this problem, reconnect this hardware device to the computer."

(Even tho the device is still connected).


I tried reconnecting, but within seconds of appearing in device manager it disappears. I have the drivers for MT65xx preloader but i do not have the time to install it as the hardware apparently is "not connected" . What could be causing this? and how do i install the drivers for MT65xx preloader, Please help me.
3 answers Last reply Best Answer
More about android driver
  1. Best answer
    Maybe use another usb port ?Did you try this:http://forum.xda-developers.com/showthread.php?t=2167621
    It says to remove the battery BUT just to make sure it is off (optional?)
  2. I made a mistake and deleted my pictures and music on my samsung galaxy III
Ask a new question

Read More

Drivers Devices Device Manager Connection Android Windows 7