Solved

new AMD build isnt working with 32 GB of RAM (only 16 GB)

I just built new PC. AMD FX-8350 cpu, ASUS Sabertooth 990FX R2.0 and 32 GB (4x8gb) G.Skill Ripjaws-X RAM. It POST to BIOS fine, heard 1 beep etc. I went to install Windows 7 Pro 64bit and i got a blue screen error. I took out 2 RAM sticks, rebooted and Windows setup worked perfectly. Why isn't it working with 32 GB of RAM? How do I get it work with all 32 GB? Thank you guys so much this have been frustrating me!
4 answers Last reply Best Answer
More about amd build isnt working ram
  1. Does it work if you use the other 2 sticks only? It could be either bad ram or bad slots on your motherboard.
  2. Make Sure the mb bios is up to date for the ram and CPU code. Also take a look at asus mb ram guild see if your ram iris listed and will the system work with 4 dimms installed.on my asus saber tooth some ram was only qal for three slots and not four.
  3. I tried using the other 2 sticks only and it works fine. Also have tried all 4 slots now so the mobo slots are fine also. Re: Smorizio- I updated all the BIOS, for RAM and CPU code. Still not working. However, I noticed my specific G.Skill RAM isn't listed on the QVL.
  4. Best answer
    I would buy ram that on the qal list or go to crucial and corsair web page and gskill and look on there qal list for tested ram.
Ask a new question

Read More

New Build RAM Memory