Solved

Sabertooth Z77 not starting with new GPU

I've started my newly built PC up before without a GPU as it came a little later. (I'm breadboarding ATM due to a faulty case).

It worked completely fine before. Now that I've inserted my GPU - a Palit GTX 670 2GB GDDR5, it won't start up.

Does anyone have any idea if there is some sort of incompatibility between these two components? Or if there's something I'm doing wrong. I have a 750W PSU, and it's all connected properly.

As I said, it still boots perfectly without the GPU inserted.
3 answers Last reply Best Answer
More about sabertooth z77 starting gpu
  1. Best answer
    It bios issue with the asus mb and video card. Asus dropped a bios patch for it a long time ago. Use your USB flashback port and flash the newest bios to the mb.
  2. Ok thanks for your reply, I'll give that a go :)

    Edit: worked a treat, thanks!
  3. James don't forget to turn on xmp profile for your ram or it may default to 1333 speeds.
Ask a new question

Read More

Sabertooth Cases Motherboards GPUs