Sign in with
Sign up | Sign in
Your question

HDD wont format past 2 percent

Last response: in Storage
Share
May 9, 2013 5:53:45 AM

Hi all,
I am repairing a friends laptop but have run into some problems!!... when trying to reformat it, using ME Boot up floppy all was going well it let me reset the parameters ok but then at the A:\ command i can type format C: it does the usual thing all data will be lost it starts to format but at 2 percent i get the dreaded error message not ready then underneath format terminated, i have tried it a few times now and sometimes get other error messages which say no fixed drives detected, aborting format, i have tried chkdsk which runs and reports no errors, the bios recognises the hard drive and allows me to change the boot sequence, however since i started getting the errors i have noticed in the bios under security tab it now sometimes says HDD frozen which can be changed if i set a user password then the HDD password states clear but it still makes no difference on the format, it also reports no cd rom drivers found! i have not got another laptop to try the drive in otherwise it would be simple enough to check if its a dead HDD so peeps if anyone has any idea's on this problem i would appreciate your input :) 
a c 81 G Storage
May 9, 2013 6:20:33 AM

What about some specs? A ME Boot up floppy will only work on a very old laptop.
a b G Storage
May 9, 2013 7:05:18 AM

How big is the hard drive? How old? When you say "ME", are you referring to that horrible operating system Windows ME which was sold for about six months in late 1999 or early 2000?
Related resources
a c 113 G Storage
May 9, 2013 7:41:22 AM

Try booting from hirem boot cd run hdtune or read the drive smart info.
Also run vendor drive test tools to see if the drive ok. If the media ok it could be a drive controller issue.
May 14, 2013 2:40:46 AM

noidea_77 said:
What about some specs? A ME Boot up floppy will only work on a very old laptop.


Hi and thanks for your input :)  the laptop is an Acer Aspire 5942 which has a Western Digital 640GB HDD, i have repaired this laptop for my friend a few times now and can only get the windows ME boot up disk's to work in it, i had tried a set of windows 7 boot up disk's but they have never worked in it, i even went as far as to re download them just in case it was a corrupt file but no i still have the same results, since my first post about this problem i have tried re setting the parameters and formatting this drive in my Toshiba Laptop and the format actually went further from the original 2% to 22% but i then got the same kind of messages that the format is terminated!!, i then tried putting my Toshiba HDD into the Acer and it took almost half an hour to load the windows so now im starting to wonder is it also something wrong with the Acer motherboard or memory, i ran a virus check but nothing was found, frustrating beyond belief lol
!