Sign in with
Sign up | Sign in
Your question
Solved

7970 extremely low texture issue on all games except warframe

Last response: in Graphics & Displays
Share
May 15, 2013 6:54:34 AM

yeah, dont quite get that last part but basically every game i play except warframe went from this

this is with my stock gigabyte 7970 that i got a year back

http://i.imgur.com/BBiSx6d.jpg

to THIS?!

http://i.imgur.com/brCyVHw.jpg
http://i.imgur.com/CwtwYuG.jpg
imagine that across every game, so far i have tested CSGO, world of warcraft (old 3.3.5 client), supreme commander: FA, The Witcher 2, guild wars 2 and warframe

for some reason, warframe looks and runs perfect still
http://i.imgur.com/OWV3QUV.jpg

May 15, 2013 7:05:50 AM

What drivers are you currently using?
m
0
l
May 15, 2013 7:10:57 AM

hizodge said:
What drivers are you currently using?


latest, i assumed updating would resolve the issue but it did not, i do not remember the version i was using before
m
0
l
May 15, 2013 7:20:11 AM

Quite strange, can you check what you CCC and GPU-Z have to say? Are they reading everything fine?
m
0
l
May 15, 2013 7:24:44 AM

hizodge said:
Quite strange, can you check what you CCC and GPU-Z have to say? Are they reading everything fine?


CCC looks fine, i dont see it not using the gpu, im almost convinced its loading terrible textures over good textures since all the games i tried are still running gpu intensive operations, its just the textures are all messed up



gpuz also looks fine
m
0
l

Best solution

May 15, 2013 7:33:56 AM

That does look normal.

Well a couple of possible fixes that quickly spring to mind:

If you're using any GPU related software other than CCC; such as Radeon Pro, MSI Afterburner, ATI Tray tools etc. uninstall them. Then try resetting everything from CCC to factory defaults and restart your computer.

If that does not work, uninstall your display drivers, restart. Run first Driver Sweeper and remove all remnants of AMD drivers. Then fire up CCleaner and run both the basic cleaner and the registry cleaner as many times as it takes for it to get rid of all errors. Restart and reinstall display drivers.
Share
May 15, 2013 7:39:05 AM

hizodge said:
That does look normal.

Well a couple of possible fixes that quickly spring to mind:

If you're using any GPU related software other than CCC; such as Radeon Pro, MSI Afterburner, ATI Tray tools etc. uninstall them. Then try resetting everything from CCC to factory defaults and restart your computer.

If that does not work, uninstall your display drivers, restart. Run first Driver Sweeper and remove all remnants of AMD drivers. Then fire up CCleaner and run both the basic cleaner and the registry cleaner as many times as it takes for it to get rid of all errors. Restart and reinstall display drivers.


ahh.... the plot thickens.....

yes i did recently install radeon pro in an attempt to run sweetfx on 64bit warframe

i shall attempt the fixes you described

Edit: i will have to attempt the fixes tomorrow, it is late and i must get up early for uni tomorrow
m
0
l
May 15, 2013 8:11:58 AM

OK. Make sure to report back.
m
0
l
May 15, 2013 10:02:30 PM

hizodge said:
That does look normal.

Well a couple of possible fixes that quickly spring to mind:

If you're using any GPU related software other than CCC; such as Radeon Pro, MSI Afterburner, ATI Tray tools etc. uninstall them. Then try resetting everything from CCC to factory defaults and restart your computer.

If that does not work, uninstall your display drivers, restart. Run first Driver Sweeper and remove all remnants of AMD drivers. Then fire up CCleaner and run both the basic cleaner and the registry cleaner as many times as it takes for it to get rid of all errors. Restart and reinstall display drivers.


praise the sun, the horrible AMD drivers have been defeated

m
0
l
May 15, 2013 10:25:54 PM

Glad to hear it! Wait until you get to try uninstalling Nvidia's drivers.
m
0
l
!