Sign in with
Sign up | Sign in
Your question

Android WiFi problem

Last response: in Wireless Networking
Share
May 16, 2013 7:08:56 AM

Hi. I have a twd_mid tablet.

Recently, I can't connect to my home's WiFi using my android. When I tried to connect the WiFi, it shows connected but with a 'lock' icon beside it. I've tried many WiFi fixer application, but it still won't work!

I even restarting my android hoping that it will work, but still doesn't work. Before this, the same problem happened where I can't connect to the WiFi because it can't obtain the IP address. I use an application called WiFix and it works.

But this time, there's an IP address, but there's still a 'lock' icon even though it says the WiFi is connected. Please help (T___T).

More about : android wifi problem

May 16, 2013 7:16:17 AM

In addition to restarting the Android, did you pull the battery? Try that. You may also need to restart your router. Unplug the router completely for half a minute or so, then plug it back in. If you go to the router's configuration page on your PC, see if it sees the Android device connected and with an IP assigned.
m
0
l
June 28, 2013 1:04:21 AM

Guys when will someone just come out and say that Android does NOT connect to the newer wifi routers because the security is set a bit higher?
m
0
l
Related resources
June 29, 2013 10:52:24 AM

Trustmeitstrue said:
Guys when will someone just come out and say that Android does NOT connect to the newer wifi routers because the security is set a bit higher?


m
0
l
June 29, 2013 10:56:57 AM

Trustmeitstrue, Is it because the security is higher, or because some of the Android hardware does not handle the higher speeds? I just ran into this problem today with a new CenturyLink modem - my newer Razr M phone connects no problem, but my older Toshiba Thrive tablet will not. Then I remembered that the Thrive also will not connect to the higher speed channel in my NetGear modem, but will connect to the lower speed channel in the NetGear modem - but evidently this is not an option in the CenturyLink modem. I am not expert in this area, so I am seeking guidance and explanation.
m
0
l
August 3, 2013 3:42:21 AM

i tried a few things to get my chinese android tablet to work with my home wifi without any success. it would show wifi connected, but not be able to access the internet. rebooting, resetting, turning wifi off and on, setting different levels of security on my router and trying different settings on the tablet. nothing worked. when i went camping recently i found that the tablet would connect to the site's wifi and be able to use the internet. so i thought that there must be some kind of conflict between my home wifi and the tablet, as the tablet would work correctly on this other wifi network.
first i thought that there might be an ip address conflict, but that seemed to be ok. then i tried altering the transmission speeds on my router. it was set at B,G and N mixed. tried them each in turn and now the tablet works fine when wireless N mode only is selected. if you are able to change this setting on your router, it is worth trying it for this kind of problem. regards, Jim.
m
0
l
!