Solved

Computer turning off after GPU upgrade

I recently bought this card
http://www.newegg.com/Product/Product.aspx?Item=N82E16814125414
and always had this PSU
http://www.newegg.com/Product/Product.aspx?Item=N82E16817379003
being used with a 8800GTX.
Turns out after I installed the 7950, I tried running the Final Fantasy 14 benchmark and Windows Experience Index. Those two makes the system shut down and it doesn't power back again unless I unplug the computer.
However, I could run a bunch of other stuff with no issues with everything maxed on 1920x1200, Dota 2, Far Cry 3 and tried Futuremark benchmarks as well so I could test if benchmarks were the problem. Also ran HeavyLoad fine.

After lots of reading and trying to find out the issue (tried diff drivers, checking voltages, and misc stuff) a friend said something about the current and asked how much amperage my PSU had. Turns out its only 16A per rail. The video card came with a 6 and a 8 pin instead of the usual 2x6. The 8 pin is connected through an exclusive rail. The 6 pin comes from the main cables where the motherboard is being connected to. I thought of using the free 6 pin rail on the PSU (I suppose its a 12v rail, it's marked as SATA though, not as PCIE) but I don't have extra cables around (nor a friend with a better PSU that I could test), with all that said is there a chance that the PSU could draw 16A from the exclusive rail and not being able to draw the rest from the shared motherboard+PCIE 6 pin one?

With all that said, is the PSU probably the culprit?

Also, since I could play a few games with no shutdowns is there a chance I might be damaging the card by playing it with underamp specs (in the case being the PSU) until I buy a better one?

Thanks in advance!
4 answers Last reply Best Answer
More about computer turning gpu upgrade
  1. Best answer
    Yes. It is very likely the PSU is the problem. 16 amps per rail is not that good for a 7950.
    You probably aren't damaging as it is, but occasionally PSUs fail after repeated stresses and if worst comes to worst it can blow your video card and motherboard.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16817139028
  2. Your PSU is the problem. You need to get something like one of these that have single rail high amps: They have 54 amps on the 12v rail and has 2 6 (8) pin PCIE power connectors. Your problems will go away with one of these.

    CORSAIR TX Series CMPSU-650TX 650W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS BRONZE $89
    http://www.newegg.com/Product/Product.aspx?Item=N82E16817139005

    Rosewill HIVE Series HIVE-750 750W Continuous @40°C, 80 PLUS BRONZE Certified, Modular De $89
    http://www.newegg.com/Product/Product.aspx?Item=N82E16817182133
  3. smeezekitty said:
    Yes. It is very likely the PSU is the problem. 16 amps per rail is not that good for a 7950.
    You probably aren't damaging as it is, but occasionally PSUs fail after repeated stresses and if worst comes to worst it can blow your video card and motherboard.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16817139028


    Anonymous said:
    Your PSU is the problem. You need to get something like one of these that have single rail high amps: They have 54 amps on the 12v rail and has 2 6 (8) pin PCIE power connectors. Your problems will go away with one of these.

    CORSAIR TX Series CMPSU-650TX 650W ATX12V / EPS12V SLI Ready CrossFire Ready 80 PLUS BRONZE $89
    http://www.newegg.com/Product/Product.aspx?Item=N82E16817139005

    Rosewill HIVE Series HIVE-750 750W Continuous @40°C, 80 PLUS BRONZE Certified, Modular De $89
    http://www.newegg.com/Product/Product.aspx?Item=N82E16817182133


    Alright, ordered me a new PSU, thanks guys!
  4. Yep, good luck
Ask a new question

Read More

Graphics