Sign-in / Sign-up
Your question

Windows Server 2008 R2 Won't Boot :(

Tags:
  • Windows Server 2008
  • Servers
  • Systems
  • NAS / RAID
Last response: in Systems
May 24, 2013 10:10:49 AM

Hi guys

I need some help with my home PC, I've made some changes recently and am now out of my depth and want to consult some knowledgeable people before progressing. The short of it is I have a HP ProLiant Microserver that I've installed WS2K8R2 on, and I've installed the AD role but having problems with it booting since doing that. I'd like to get it booting again and then into the state I need it.

So, the state was with my 2 home PC's:

HP ProLiant Microserver
250gb SATA system drive (with Windows 7)
2x 3Tb SATA data drives
2x 500gb SATA data drives

Shuttle SH67H7
128gb SSD system drive (with Windows 7)
1Tb SATA data drive
Bluray writer

My initial motivation for change was to have 2 more 3Tb data drives in the Microserver, and also have a level of redundancy using RAID. I decided to go for Windows Server 2008 R2 with RAID-5. So, after moving data around all over the place and swapping drives left right and centre, I ended up with a server with WS2K8R2 on, and 4x 3Tb drives. I configured them in RAID and ended up with a nice 8.1Tb partition ready to use.

The problem I had at this point was that every time I tried to copy files from the Shuttle to the Microserver, it kept asking for credentials, and I thought it would be far easier if I had a single user across both machines. It would also make sense to have an account for the wife, and maybe a couple for the kids in a few years. So, I decided to add the Active Directory role to the server, to go down this path. Unfortunately I have very little experience in setting up domains etc so this was a bit of a punt, but I thought i'd go for it. In hindsight, this is probably massive overkill, but I thought I'd try anyway!!

Once this was installed, I set up a forest and then it asked me to reboot, here is where the problems began. Windows no longer booted up, it just sat for ages on the screen with the Knight Rider style green bar and 'Microsoft Corporation', it would eventually get to a blank black screen with a mouse pointer, and nothing else. I turned it off, unplugged all 4 RAID disks and tried again, still no luck. In the end I went into the Windows Recovery Environment and ran the memory check - no problems, then ended up going to the command prompt. At this point I realised that the only 2 disks that it thought were available were D: and X: - odd as the OS was on C: before.

I tried following the changes here:

http://support.microsoft.com/kb/947288

But it made no difference, and going back into the WindowsRE I found that the registry had reverted to how it was before anyway.

Another search led me to this forum where I found this thread:

http://www.tomshardware.co.uk/forum/237848-45-changed-drive-letters-computer-boot

I tried the changes suggested by the user ingrave which involved setting a different partition active, but now where I reboot the computer gives me the message

Quote:
BOOTMGR missing press Ctrl-Alt-Del to restart


I can't seem to get into WindowsRE anymore, so I am stuck. This is where I currently am and not sure where to go next. I thought before I make it worse I'd ask for help!!

Here are the options that I think I have:
1. Find a way to fix the issues with the bootdisk and get the system up and running again. This would be the best result although whether I should have AD on the machine or not I don't know.

2. Reformat the boot drive and install WS2K8R2 again. I don't mind doing this as there is nothing on the drive that I specifically need, it's all but a new install. My concern here is that I'd lose the data on the RAID, as I don't know if it's tied in to Windows or not. If I could get to that data, I have enough drives to move it off, I could start again with the whole lot.

There may be other options but I've not really thought hard enough yet. If anyone has any suggestions then I'd love to hear them. Happy to provide more information if I've missed anything.

Thanks in advance!!!

More about : windows server 2008 boot

May 24, 2013 11:29:04 AM

have you tried these steps?

1.Put the Windows installation disc in the disc drive, and then start the computer.
2.Press a key when the message Press any key to boot from CD or DVD appears.
3.Select a language, a time, a currency, a keyboard or another input method, and then click Next.
4.Click Repair your computer.
5.Click the operating system that you want to repair, and then click Next.
6.In the System Recovery Options dialog box, click Command Prompt.
7.Type Bootrec /RebuildBcd, and then press ENTER.

m
0
l
May 24, 2013 1:18:18 PM

Hi everlost

I hadn't tried that as the server doesn't have an optical drive in, but i've just switched everything around so i now how the BD drive and the boot drive in the server. After clicking Repair your computer it gives me a dialog to choose between repairing an OS, and restoring with a system image - unfortunately the list box with the OS's in is empty ... not ideal.

Looks like I need to hunt down some drivers for my HDD. Interestingly when I click OK to choose the drivers I get the standard file selection dialog, looking at the drives it has Local Disk (C: ), System Reserved (D: ) and Boot (X: ). Grrr. Assume I need to get the drivers for the HDD, pop them on a USB stick and use that or something?

Unless there are any other suggestions I'll do that now.
m
0
l
Related resources
May 24, 2013 2:00:58 PM

According to the Seagate website, I don't need drivers for the HDD as Windows should already have them on board.

I did manage to get to the command prompt by cancelling though, so I tried bootrec /rebuildbcd

It found Windows on C:, so I added that. Rebooted and it failed again, so back into the recovery options, and this time it found the drive. Selected it, hit next, into command prompt but it's put me at X:. I switched to C: and ran the same bootrec command and this time I get:

Quote:

Successfully scanned Windows installations.
Total identified Windows installations: 0
The operation completed successfully.


Going to reboot now, if anyone has any suggestions that would be appreciated as I feel I'm going round in circles a bit. Thanks!
m
0
l
May 25, 2013 5:58:16 PM

I seem to be getting further with this now, I'm at a point where I can get everything to boot if I plug the OS drive into any of the 4 HDD slots in the lower part of the ProLiant, but if I plug it into the top bay and the SATA cable that uses, then it doesn't boot.

I've tried running DiskPart in both the booted OS and also in the WindowsRE when it doesn't boot, and I get the following differences:

When disk in a lower bay and Windows booted:

  1. Microsoft DiskPart version 6.1.7601
  2. Copyright (C) 1999-2008 Microsoft Corporation.
  3. On computer: SERVER
  4.  
  5. DISKPART> list vol
  6. Volume ### Ltr Label Fs Type Size Status Info
  7. ---------- --- ----------- ----- ---------- ------- --------- --------
  8. Volume 0 System Rese NTFS Partition 100 MB Healthy System
  9. Volume 1 C NTFS Partition 232 GB Healthy Boot


When I switch the drive over and boot into the WindowsRE:

  1. Microsoft DiskPart version 6.1.7601
  2. Copyright (C) 1999-2008 Microsoft Corporation.
  3. On computer: MININT-LC55RLS
  4.  
  5. DISKPART> list vol
  6. Volume ### Ltr Label Fs Type Size Status Info
  7. ---------- --- ----------- ----- ---------- ------- --------- --------
  8. Volume 0 C System Rese NTFS Partition 100 MB Healthy
  9. Volume 1 D NTFS Partition 232 GB Healthy


Problems with the second results here that I see:
1. The computer name has disappeared (it's called SERVER)
2. The System Reserved partition now has the drive letter C.
3. The Info column is empty.

Also the dialog presented by the WindowsRE tells me that the operating system is "Windows Server 2008 R2 on (D: ) Local Disk". Why has it switched letters? How do I get it back?

Any help appreciated in advance.
m
0
l
May 25, 2013 11:55:06 PM

I would check your bios settings. And check to see if your sata cable is loose on the motherboard.

I believe the 4 lower bays are on an SAS backplane and your upper 2 (?) are sata. I would also look for an up to date version of the SAS controllers drivers, windows setup drivers my not be good enough.
m
0
l
May 26, 2013 1:32:15 AM

everlost said:
I would check your bios settings. And check to see if your sata cable is loose on the motherboard.

I believe the 4 lower bays are on an SAS backplane and your upper 2 (?) are sata. I would also look for an up to date version of the SAS controllers drivers, windows setup drivers my not be good enough.


What settings am I looking for in the BIOS? I know the computer recognises the HDD as it's set at the top of the list of boot devices (it's the only device on there). I think the SATA cables is seated properly but I will double check.

The pc booted from this drive in this configuration before I installed AD, so I think all the necessary drivers should be in place. I don't know about SAS, it's a HP ProLiant MicroServer N40L if that helps.

Appreciate your help, thanks. I'll try looking for drivers but I have a feeling it's a configuration issue.

m
0
l
May 26, 2013 9:44:18 AM

I found this (http://www.avforums.com/forums/networking-nas/1429720-t...). This is closest to your hardware setup I could find. He make some tweaks in the bios to get it to work. Since you already had the hardware working, this may not be useful. And he had some OS specific settings that would work against you.

Others have reported that the sata cables can come loose when sliding the motherboard back. This could explain hdds not detecting.

I would try to undo anything you have done to the partitions (active,letter assignment), verify your OS partition is "c" again, then try bootrec again. Lookup the other bootrec options, they may help.

You may have to remove your raid drives and reinstall windows. This link (http://forums.overclockers.com.au/showpost.php?p=132219...) steps you through turning a non-raid setup into a raid setup with out reinstalling. I bring this up in case you want to get windows setup and then add your raid later.

Sorry about links. I'm posting from an iOS device, and can't remember the code for embedding links.
m
0
l