Sign in with
Sign up | Sign in
Your question

Performance issues game-to-game: possible bottleneck?

Last response: in CPUs
Share
May 26, 2013 5:14:27 PM

Hello,

I'm facing some performance issues with my computer. Some games it gives decent performance, in some games not. For example, I got 59-60 FPS in 1440x900 resolution and low-normal quality on League of Legends. I can play Team Fortress 2 low-normal quality too. But I can't play Command & Conquer 3: Red Alert, Age of Empires Online on low settings with same resolution smoothly, it is hanging while roaming on map. In Cabal Online, it is hanging too while moving around.

I posted the specs and temperatures on below:

AMD Athlon II X2 240 @ 2.8 Ghz
AMD Radeon HD 5770 1 GB
ASUS M4A785D-M PRO
4 GB DDR2 @ 400 Mhz, 6-6-6-18 (3 GB usable due to 32-bit Windows 7)
OCZ ZS 750W

CPU temp. is 28-30 degrees at idle, 38-40 degrees in game. (It has stock CPU fan)
Motherboard temp. is 36-40 degrees both idle and in game.
GPU temp. is 40-41 degrees at idle, in game I don't know.
My case has one 120 mm front and one 120 mm rear fan.

That is all about story. I'm looking for some answers about my problem. I suspect that my CPU and graphic card have bottleneck. But I don't know how to figure out it is.

Thank you for your helps and sorry for grammer errors in my English.
a b à CPUs
May 27, 2013 7:11:18 AM

Your CPU is the bottleneck-- but that's extreme.

You should be able to play atleast C&C and AoE... Sounds like there may be some software related issues as well.
m
0
l
May 27, 2013 1:12:50 PM

hafijur said:
Your processor is the problem. Download gpuz and go on sensors in gpuz and run a game and see what gpu load is. If vsync in game is off and your not getting 99% gpu load most of the time this means its a cpu bottleneck unless game is not optimised. Anyway I qouldn;t be suprised if you get similar fps on higher settings as you are limited by the cpu and lower settings require more cpu power to push those frames up especially at lower resolution.


Here are some pictures I took from while playing League of Legends.

My Graphic Card at Idle



1440x900, All Options as High, No Shadows without Vsync

Note: When I applied the changes, my FPS started to change around 75-96 FPS. first, after looking to GPU-Z, it started to change around 50-75 FPS



1440x900, All Options as High, No Shadows with Vsync



elemein said:
Your CPU is the bottleneck-- but that's extreme.

You should be able to play atleast C&C and AoE... Sounds like there may be some software related issues as well.


I don't know why but I can play these games before. Whenever I updated Catalyst Control Center on March it burned all of my experiences with these games. I don't think it is a software situation but I can give which information you need to detect my problem is related to some software.

Thank you.
m
0
l
Related resources
May 27, 2013 1:28:03 PM

hafijur said:
Do you have any integrated graphics with your motherboard. I would advise upon updating latest catalyst driver and setting games individually to use the ati card. I think you maybe using an integrated graphics card click on gpuz bottom part on ati radeon hd 5700 series as you shown on picture. It could be that its using the integrated card for games with the motherboard if there is such thing. Your gpu temps suggest to me your gpu is not being used for gaming, maybe just for the operating system only.


Yes... I've ATI Radeon HD 4200 as integrated graphic card. How can I set my HD 5770 as gaming card? Do you want to me take HD 4200's photos too while runinng LoL and GPU-Z in background?
m
0
l
May 27, 2013 1:55:53 PM

hafijur said:
Well I have an i5 3317u with integrated hd 4000 and nvidia 640m, on some games I have to set the nvidia 640m using nvidia control panel manage 3d settings and adding games and making it use the high performance nvidia processor. I am sure on ati catalyst there should be an option to add games and choose it to use the 5770. I am not familar with catalyst though as my desktop with a hd 6850 I don't use it much. I am sure you will find a place to add games for 3dsettings then out of the 2 graphics card choose hd 5770.


No way, I don't have any second option in GPU-Z. It has only ATI Radeon HD 5700 Series and on Catalyst Control Centers' options it is showing HD 5770 too.

m
0
l
a b à CPUs
May 27, 2013 2:50:41 PM

Humanoid said:
Hello,

I'm facing some performance issues with my computer. Some games it gives decent performance, in some games not. For example, I got 59-60 FPS in 1440x900 resolution and low-normal quality on League of Legends. I can play Team Fortress 2 low-normal quality too. But I can't play Command & Conquer 3: Red Alert, Age of Empires Online on low settings with same resolution smoothly, it is hanging while roaming on map. In Cabal Online, it is hanging too while moving around.

I posted the specs and temperatures on below:

AMD Athlon II X2 240 @ 2.8 Ghz
AMD Radeon HD 5770 1 GB
ASUS M4A785D-M PRO
4 GB DDR2 @ 400 Mhz, 6-6-6-18 (3 GB usable due to 32-bit Windows 7)
OCZ ZS 750W

CPU temp. is 28-30 degrees at idle, 38-40 degrees in game. (It has stock CPU fan)
Motherboard temp. is 36-40 degrees both idle and in game.
GPU temp. is 40-41 degrees at idle, in game I don't know.
My case has one 120 mm front and one 120 mm rear fan.

That is all about story. I'm looking for some answers about my problem. I suspect that my CPU and graphic card have bottleneck. But I don't know how to figure out it is.

Thank you for your helps and sorry for grammer errors in my English.


Overclock your athlon you can get to 3.8ghz very stable with VCore changes it is causing the issues.
m
0
l
May 27, 2013 3:37:13 PM

catshannon said:
Humanoid said:
Hello,

I'm facing some performance issues with my computer. Some games it gives decent performance, in some games not. For example, I got 59-60 FPS in 1440x900 resolution and low-normal quality on League of Legends. I can play Team Fortress 2 low-normal quality too. But I can't play Command & Conquer 3: Red Alert, Age of Empires Online on low settings with same resolution smoothly, it is hanging while roaming on map. In Cabal Online, it is hanging too while moving around.

I posted the specs and temperatures on below:

AMD Athlon II X2 240 @ 2.8 Ghz
AMD Radeon HD 5770 1 GB
ASUS M4A785D-M PRO
4 GB DDR2 @ 400 Mhz, 6-6-6-18 (3 GB usable due to 32-bit Windows 7)
OCZ ZS 750W

CPU temp. is 28-30 degrees at idle, 38-40 degrees in game. (It has stock CPU fan)
Motherboard temp. is 36-40 degrees both idle and in game.
GPU temp. is 40-41 degrees at idle, in game I don't know.
My case has one 120 mm front and one 120 mm rear fan.

That is all about story. I'm looking for some answers about my problem. I suspect that my CPU and graphic card have bottleneck. But I don't know how to figure out it is.

Thank you for your helps and sorry for grammer errors in my English.


Overclock your athlon you can get to 3.8ghz very stable with VCore changes it is causing the issues.


Thank you. In addition to if I replace my CPU with Phenom II X4 965 BE or Athlon II X4 640 will it solve my issue too?
m
0
l
a b à CPUs
May 27, 2013 5:12:58 PM

Humanoid said:

Thank you. In addition to if I replace my CPU with Phenom II X4 965 BE or Athlon II X4 640 will it solve my issue too?


Yes, it will greatly raise the performance and potential with the Phenom II; though the Athlon II option may not increase much performance if the extra cores are not used. However, make sure your motherboard supports these CPUs.

m
0
l
a b à CPUs
May 28, 2013 10:07:58 AM

Humanoid said:
catshannon said:
Humanoid said:
Hello,

I'm facing some performance issues with my computer. Some games it gives decent performance, in some games not. For example, I got 59-60 FPS in 1440x900 resolution and low-normal quality on League of Legends. I can play Team Fortress 2 low-normal quality too. But I can't play Command & Conquer 3: Red Alert, Age of Empires Online on low settings with same resolution smoothly, it is hanging while roaming on map. In Cabal Online, it is hanging too while moving around.

I posted the specs and temperatures on below:

AMD Athlon II X2 240 @ 2.8 Ghz
AMD Radeon HD 5770 1 GB
ASUS M4A785D-M PRO
4 GB DDR2 @ 400 Mhz, 6-6-6-18 (3 GB usable due to 32-bit Windows 7)
OCZ ZS 750W

CPU temp. is 28-30 degrees at idle, 38-40 degrees in game. (It has stock CPU fan)
Motherboard temp. is 36-40 degrees both idle and in game.
GPU temp. is 40-41 degrees at idle, in game I don't know.
My case has one 120 mm front and one 120 mm rear fan.

That is all about story. I'm looking for some answers about my problem. I suspect that my CPU and graphic card have bottleneck. But I don't know how to figure out it is.

Thank you for your helps and sorry for grammer errors in my English.


Overclock your athlon you can get to 3.8ghz very stable with VCore changes it is causing the issues.


Thank you. In addition to if I replace my CPU with Phenom II X4 965 BE or Athlon II X4 640 will it solve my issue too?


Take the 965be i love it able to play bf3 on ultra 64 players and with a good gpu you will get 28 fps+
m
0
l
May 29, 2013 4:18:13 AM

Thank you all. I will change my CPU as nearly as possible. I will wait for Haswell CPUs. Maybe, I can change my motherboard, CPU and RAMs together.
m
0
l
!