Closed Solved

Internet Explorer Issues / Internet Options won't open / Inetcpl.cpl error

PROBLEM SOLVED: Look below (under summary of problems) for the solution.

Hey,

SUMMARY OF PROBLEMS

- Cannot open Internet Explorer: When I open IE 9, the process appears, and internet explorer starts up. As soon as the tab for my homepage loads, IE closes straight away, and leaves behind the download manager for IE, asking me if i want to download my homepage.

- Cannot open Internet Options through control panel: When i go to Control Panel > Networking > Internet Options and click on it, nothing appears on screen, no matter how many times i press it. Same thing happens with IE > Tools > Options; nothing appears

- Cannot open Skype (I found this was linked to the IE problems): When I open Skype, the login page stays on a white screen, and i am unable to click anywhere on skype / close it, I have to force close it by ending the process (Temporary solution found, look below)

- Cumulative Security Update for IE 9 won't install (Windows Update): This has been an on-going problem for around a year+ now, but still relevant. Whenever my Windows Update has a Cumulative Security Update for IE 9, I try to install it, however it fails and says updates were not configured correctly, reverting changes The error code I get is: 800719E4. As far as I am aware, there is no solution to this error as of yet.

SOLUTION

This was caused by multiple Windows Updates that were released in May 2013 - KB2820197 AND KB2847204

How to fix this:

1. Go to Start > Control Panel > Programs > View Installed Updates
2. Find the windows updates:
- KB2820197
- KB2847204

3. Right click on them and press uninstall.
4. Reboot the computer.

WHAT I HAD TRIED, AND FAILED (For reference)

1. Uninstalling Internet Explorer 9 and reinstalling (get an error message on uninstalling: updates were not configured correctly, reverting changes)
2. Trying an sfc /scannow through cmd - it found a few corrupt files and fixed them but didn't solve the problem.
3. Booting up IE from a fresh boot with no network connection - can open it but can't access tools > internet options
4. Booted in safe mode and safe mode with networking to try and access the control panel internet options / IE > tools > options, but didn't work.
5. Tried running Inetcpl.cpl, nothing opened.
6. Went to the microsoft help page: http://support.microsoft.com/kb/923737
and downloaded the reset internet explorer fix, when it was attempting to fix the problem, i got the error: Error loading inetcpl.cpl. The Operating system cannot run %1
7. [Skype related] Tried deleting shared.xml file in %appdata% > Skype, however that didn't work
8. Tried straight up installing a previous version of IE (IE 8) but it doesn't let you install a previous version of IE if you already have the most recent one (And i'm unable to uninstall the current version of IE)
9. Tried editing the registry key in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Restrictions and deleting NoBrowserOptions but the entry Internet Explorer does not exist

PROBLEMS / FIXES

1. Fixed Skype temporarily by creating a shortcut of the original Skype, and changing the target to "C:\Program Files\Skype\Phone\Skype.exe" /legacylogin - allowing me to log in and use skype
2. Did a few indepth antivirus scans and found a Trojan.Vundo in the Internet Explorer Registry file: HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes\{56256A51-B582-467e-B8D4-7786EDA79AE0} However, after removing it, IE still didn't work.

Other Info / specs

- Running a 32 bit OS + 32 bit IE
- Using IE 9
- Fully patched Windows (All windows updates complete aside from IE Cumlative Security updates)
- Running Service Pack 2
32 answers Last reply Best Answer
More about internet explorer issues internet options open inetcpl cpl error
  1. phaled

    Try to change the Internet Explorer settings that may be resolve many types of problems.
    follow these steps...
    -Open Internet Explorer.
    -Click Tools from the Menu bar (if the Menu bar is not displayed, press Alt to open it), then click Internet Options .
    -Click the Advanced tab.
    -Click Reset .
    -When done, close all open Internet Explorer windows, reopen Internet Explorer, then try to view the Web page again.
  2. I can't open Internet Explorer, that's the problem, it just closes itself straight away
  3. It's Skype, it's trying to access Port:80 which other internet & programs require, you just need to close Skype then open it agian, it may appear to do a re-install but it is just re-configuring itself.
  4. I've opened + closed skype many times, i've also uninstalled it + reinstalled it and tried previous versions of Skype, none of them work.

    I can get onto Skype by changing the shortcut target to a legacy version, but I still have the IE issues + not being able to open skype normally.
  5. Do it when IE is open.

    I only read about the Skype issue elsewhere because so many other users were having the same issues and all of the threads referred to using Skype when their issues occurred. I actually have never used Skype so I"m only going by what I read...

    You have to pay for Skype, it's not free. You need an account.
    https://support.skype.com/en/faq/FA351/how-can-i-pay-for-skype-products

    I've found a solution of sorts that might fix your issues, it applies to IE, Vista And Windows 7 -
    http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/cannot-open-skype-since-upgrading-ie9/0789ad3d-9b27-43ba-ba79-007331a017c2
    1. Close Skype.
    a. Right-click the Skype icon in the system tray (at the bottom right of the screen)
    b. Choose Quit.
    2. Ensure that “Show hidden files and folders” is switched on.
    a. Click Start, type run and press Enter.
    b. Type control folders and click OK.
    c. Select the View tab and ensure relevant entry is enabled.
    3. Locate the shared.xml file.
    a. Click Start, type run and press Enter.
    b. Type %appdata%\skype and click OK.
    c. Delete the shared.xml file.
    4. Restart Skype. The shared.xml file will be recreated.
  6. I tried deleting shared.xml and unfortunatly that didn't work.
  7. Why are you using internet exploder anyway? Firefox is much better.
  8. I'm not using internet explorer at all, I use Chrome. You need Internet explorer installed to run core windows items (like skype and to get into your networking settings in the control panel) I just need to fix IE to be able to get into those things, when IE is corrupt, there are quite a number of things you cannot do.
  9. When you get to desktop from a cold boot, close all running programs so you only have the desktop showing then open IE without the network connection so it opens up in Offline mode then you make your changes.
  10. When i'm disconnected from a network, I can open IE, but when I go to Tools > IE options, I click it but nothing opens up.
  11. Are you using IE x32 or IE x64. To use IE x64, you have to have IE x32 installed as well.

    Don't have skype running or Chrome or whatever other apps in the background.

    If the issue persists, try playing Spider Solitaire to test out whether the video card is acting up.
  12. I'm running 32 bit, and i tried from a fresh boot with nothing running and it still doesn't work :/ + my graphics card is fine
  13. What is the Legacy version of Skype?
    According to a Skype Download page, version Skype 3.8.0.188 is the most popular even though the latest version is Skype 6.1.0.129
    http://www.oldversion.com/windows/skype/

    What version/s are you using?\

    Edit - Where did you get your version of IE9 and is it English Language? Not sure if the language is an issue, just hought I'd ask, anyhow

    http://windows.microsoft.com/en-US/internet-explorer/downloads/ie-9/worldwide-languages
  14. I'm not sure what Legacy Skype version it is, I created a new shortcut from the original Skype, and changed the target to: "C:\Program Files\Skype\Phone\Skype.exe" /legacylogin

    I've had IE 9 for at least a few years or whenever it was released in a windows update, and yes, it's english.

    UPDATE: I went to http://support.microsoft.com/kb/923737 and downloaded the reset internet explorer fix, when it was attempting to fix the problem, i got the error:

    Error loading inetcpl.cpl. The Operating system cannot run %1
  15. CPL refers to Control Panel, it seems not to be able to add an icon shortcut in it.

    inet could refer to your iiNet Service - http://www.inet.com.au/broadband.shtml

    What is your broadband service? Is it compliant with your current OS?

    What version is your Skype?
  16. Inetcpl.cpl is the part of the control panel that lets you access your internet properties, and my version of skype is 6.3 i believe.

    Don't think it's anything to do with my broadband, it's probably a corrupt file in system 32.
  17. The Skype issue is widespread, not many users are willing to accept that Skype is the problem and are blaming other things.
    Skype 6.3 is for both Windows and Mac, both the same verison number, perhaps you downloaded the Mac version instead of the Windows version?

    "Skype 6.3 for Windows is a maintenance release which brings to you a set of quality and performance related improvements."
    A manintenace release? Sounds like a hotfix.

    Consider uninstalling Skype, do a restart of PC, then install version 6.1, many users are finding it more compatible with Windows 7.

    Edit - Skype 6.1 for Windows 7 but might be good for Vista.

    Edit 2 -
    what is your anti-virus sfotware? Perhaps try out MSE, it's free and does do a good job. AVG is also free and also does good, too.

    It's most likely going to end up being a virus issue, I expect so you will need to run a full scan on all files and folders in the root directory of C: which may take as long as 3 hours but don't have the program delete anything, move to vault would be best, and "clean".
  18. Quote:
    The Skype issue is widespread, not many users are willing to accept that Skype is the problem and are blaming other things.


    Like I said, I've found a temporary solution to the Skype issue, and i'm perfectly happy with the outcome of it. However, the problem of Internet Explorer, internet properties and the possibility of corrupt system 32 files is still a big problem.

    I'm unwilling to accept that it's a Skype issue simply because i've uninstalled it and reinstalled it, tried installing previous versions and tried booting it up from safe mode - none of them work. There is also so much evidence that the skype issue is related with an error with inetcpl.cpl from what i've been reading.

    I've also done full system scans with: Hitman Pro, GMER, TDSSkiller, Norton, Prevx and Malware Bytes - it's not a virus issue.

    But just to reiterate, I've fixed Skype for now, i just need a solution to my inetcpl.cpl error
  19. How did you fix Skype (just for future reference)?
    http://support.microsoft.com/kb/216583

    1.Click Start, click Run, and then type regedit in the Open box, and then click OK.
    2.Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Restrictions

    3.If a value named NoBrowserOptions exists, delete it.
    4.Locate and then click the following key in the registry:
    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Internet Explorer\Restrictions

    5.If a value named NoBrowserOptions exists, delete it.
    6.If you are using 64 bit version of Windows, locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\Internet Explorer\Restrictions

    7.If a value named NoBrowserOptions exists, delete it.
    8.Restart the computer.
  20. I edited my 1st post on the thread for all the fixes / what i've tried, look there for what i did to fix skype for now.

    And I already tried editing the registry , but the entry internet explorer doesn't exist within the Microsoft entry.
  21. Log in as Administrator -
    Reset IE9

    Skype hints

    Otherwise, try a Roll-Back for IE in Control Panel.

    Edit - you should install the IE Cumlative Security updates.
    Cumulative updates bulletin

    Also, if you can somehow get into the browser, add-ins, enable ActiveX and javascript, do it offline.
    You may need to uninstall Google (Chrome) before installing IE.
    What version Google (Chrome) are you using?

    What Service Pack Vista? You need Service Pack 2, there are no updates available for Service Pack 1.
  22. I can't reset IE, won't let me into that part to reset it, tried rolling IE back to a previous state but on the restart it says updates were not configured correctly, and I can't install the IE cumulative updates for that reason too. i'm on Serive Pack 2 and running the latest version of chrome
  23. You refer to the Vundo virus, that is a rather severe virus, you just can't delete it yourself, you need to have it removed with anti-virus software. Most viruses have a back up plan so if a user deletes the file, it replicates itself elsewhere on the root drive.

    Uninstall ALL of your browsers then restart then install IE to see if it will take being the only browser present.

    Edit - I also had issues with IE but only when combined with Chrome.... I refuse to allow Google anything on this PC not that it isn't any good but just not suited to my experience (Google is a TH sponsor)
  24. Can you run the Control Panel>Internet Options by typing inetcpl.cpl in the Run box in Safe Mode? While you're there, try a few more .cpl commands.
  25. Can't run intecpl.net from safe mode, and i can use more of .cpl, it's just the internet options related ones i can't use.
  26. With Google Chrome, you need the IE installed prior to Chrome so considering all the changes to IE, your Chrome is the culprit and not IE.
    You could try setting Chrome as NOT the default browser, IE should actually be the default browser, anyhow. Chrome also utilises the ieframe.dll

    If you do decide to uninstall Chrome, all your settings for it will also be removed.
  27. You're going to need to reconstitute that part of the Control panel by using your (or a borrowed) XP CD. If you do need to borrow one, I doubt it would make a difference whether it was Home or Pro. Pop the disk in and close the blue form that shows up. Go from Start to Run and in the Open box, type the following:-
    expand D:\i386\inetcpl.cp_ C:\Windows\system32\inetcpl.cpl
    then press Enter. The _ is correct - unexpanded files don't get their last character back until they're ready for use. I've assumed here that D is your optical drive and C is (a it should be) your OS drive.
  28. Does it have to be straight from a disc, or can I go around to my friends house and take his intecpl.cpl and copy + replace it in system 32? Also, does it matter if it's from a 64 /32 bit system considering i'm running a 32 bit OS.
  29. It has to be worth a shot and I can think of no reason why a 64 bit version of a single file would be any different from the 32 bit. Give it a go and you didn't hear this from me if the system gets hosed. :D
  30. It has to be worth a shot and I can think of no reason why a 64 bit version of a single file would be any different from the 32 bit....


    Makes a HUGE difference. 32-bit OS will not run a 64-bit binary.
  31. OK - my bad. I thought it didn't matter at individual file level. Does it appear in the System 32 or the WOW64 folder?
  32. Best answer
    I've finally solved it.

    Turns out it was an error caused by windows updates:

    - KB2820197
    - KB2847204

    I just uninstalled them + rebooted and everything seems to be working normally now.

    Cheers for everyone who helped on this.
Ask a new question

Read More

Windows Vista Control Panel Internet Download Internet Explorer White Screen