Sign in with
Sign up | Sign in
Your question

Building custom pc, can't get picture to monitor.

Last response: in Systems
Share
May 27, 2013 8:09:17 AM

I've just put together my new pc, it's powering up, graphics card is powered, liquid cooling is working, 4/5 fans are working, and even some controls on the case are working. However, I can't seem to get a picture to my monitor. I'm just trying to get bios so I can begin working on my pc. Also I've been trying to get my mouse and keyboard connected (both usb) and my mouse will get power for a few seconds when I plug it into the usb ports, and I'm not sure if this is because of wiring. I have a feeling that both of my issues are coming from the wiring, but i'm not completely sure because the books and guides that came with my motherboard and case aren't specific enough when dealing with all of the wires. Appreciate any feedback.
May 27, 2013 8:52:40 AM

Can you list the hardware you have used?
m
0
l
May 27, 2013 10:03:46 AM

Yea, no problem, here's what I'm working with.

Case: CM Storm Trooper (Stryker)
Motherboard: ASRock Z77 Extreme 6
Processor: Intel Core i7-3770K
RAM: Ballistix by Crucial (16GB KIT, 2 - 8GB)
Hard Drive: Samsung SSD 840 PRO Series (128GB)
Data Drive: WD Black Desktop (1TB)
Graphics: EVGA GeForce GTX 670 FTW
Power Unit: Corsair TX 750 (80 Plus Bronze)
Cooling unit: Corsair H80i Liquid Cooling
Wireless Internet: TP-Link 450 Mbps Wireless N Dual Band, PCI Express Adapter
Keyboard and Mouse: USB
Monitor: Samsung 22 Inch
m
0
l
May 27, 2013 1:43:53 PM

Ok, the hardware looks good so far.

Is it possible to take a photo of the mainboard in your case? Just to see if the wiring is done correctly.
m
0
l
!