Sign in with
Sign up | Sign in
Your question

Need help! Can't get signal from computer to monitor. (currently plugged into vga in mobo trying for bios)(my build inside)

Last response: in Motherboards
Share
May 27, 2013 12:22:59 PM

Hello all, this is my first time building a computer from scratch. So far everything has gone relatively well, except for the fact that I now can't get anything to show up on my monitor. This is my build. I've used multiple monitors and put the RAM in separate slots with multiple reboots. I'm simply trying to get any kind of signal to my monitors, (which I'm assuming would be bios). Even though it's my first time wiring, I feel as if the wires are where they need to be. I have some extra wires, but they don't seem to fit anything else on the motherboard or power unit. All of my fans are working, as well as my cooling unit, the graphics card fan is also spinning, my power button on my case works, as well as the fan speed and LED light controls. My only other problem would be that I can't get the mouse and keyboard to work either. When I plug in the mouse, it lights up for a few seconds and then the light goes away. My hard drive doesn't have anything on it yet, so I've read that USB 3.0's can't read a mouse or keyboard because there's a driver needed for it, and I'm unsure if I have any USB 2.0 ports (which apparently don't need drivers). I've been working on this for a few days and looked at endless threads. Any help would really be appreciated. Thanks.

Case: CM Storm Trooper (Stryker)
Motherboard: ASRock Z77 Extreme 6
Processor: Intel Core i7-3770K
RAM: Ballistix by Crucial (16GB KIT, 2 - 8GB)
Hard Drive: Samsung SSD 840 PRO Series (128GB)
Data Drive: WD Black Desktop (1TB)
Graphics: EVGA GeForce GTX 670 FTW
Power Unit: Corsair TX 750 (80 Plus Bronze)
Cooling unit: Corsair H80i Liquid Cooling
Wireless Internet: TP-Link 450 Mbps Wireless N Dual Band, PCI Express Adapter
Keyboard and Mouse: USB
Monitor: Samsung 22 Inch
a b V Motherboard
May 27, 2013 12:29:58 PM

yes theres 2 x usb 2.0 ports on the rear

they will have a black insert and usb 3.0 will be blue

make sure you are connecting the monitor to the graphics card and not the integrated graphics
m
0
l
a b C Monitor
a b V Motherboard
May 27, 2013 12:39:24 PM

Either that or don't put in the graphics card initially and boot off the mb.
m
0
l
!