Sign in with
Sign up | Sign in
Your question

Something seriously wrong with my ATI Radeon Hd 4200

Last response: in Graphics & Displays
Share
June 6, 2013 2:03:01 PM

So let me start off by saying I don't know anything about computers, I just want them to run and play I never paid much attention to the details.

But lately my graphics card is so bad it gets artifacts (so bad I can hardly recognize anything) on old games like Morrowind for God's sake. I looked around and downloaded this thing called GPU-Z to see the temperature but it doesnt tell me that, all it tells me is some BS about clock usage or something(Memory clock at about 400 MHz and core clock at about 500 MHz).

One more thing I noticed is, when I activated the render test, the GPU load went up to 100% and the memory usage went down to like 70MB. Surely this can't be good?

I don't know what's relevant so I'll post some random computer specs:
Processor: AMD Athlon II X4 630 Processor (4CPUs) ~2.86 GHz
Memory: 6144 MB RAM
DirectX Version: DirectX 11
Windows 7 64 bit

More about : wrong ati radeon 4200

June 6, 2013 2:08:47 PM

you need a stand alone (discreet) graphics card. the 4200 is on board video/graphics.
June 6, 2013 6:10:54 PM

swifty_morgan said:
you need a stand alone (discreet) graphics card. the 4200 is on board video/graphics.


What about the XFX Radeon HD 6770?
Related resources
June 6, 2013 6:13:58 PM

sure, as long as you have the slot for it.
June 6, 2013 6:44:41 PM

Hey I figured it out!!

All you have to do is roll back the drivers and it fixes everything
!