Sign in with
Sign up | Sign in
Your question

Gigabyte Z87X-UD3H BIOS not detecting SSD and one of my HDD's, also won't boot Win 7 install disc

Last response: in Motherboards
Share
June 7, 2013 2:43:17 PM

Just completed a new Haswell build this morning, however the BIOS/UEFI isn't detecting the SSD and my old 1TB HDD. It's only detecting the optical drive and my 3TB HDD.


I've tried various configurations of different data and power cables and tried different SATA ports on the mobo.

I've tried different settings in the BIOS, I've made sure SATA mode is set to AHCI and have tried switching it to IDE and RAID just to see if that might detect it with no luck. All the SATA ports are enabled. I've tried various combinations of legacy boot settings with no luck.

I've flashed the BIOS to the latest version (F5) with no change. I've also tried switching to the backup BIOS with no change.

I'm pretty sure both drives are good, the 1TB has been in use for years as the boot drive in my old build, and I tested the SSD the other day in an external HUB with my laptop and it was detecting it.

I'm also being frustrated by the systems refusal to boot from the Windows install discs. The discs are good and are able to boot my laptop, and the CD drive was able to boot a firmware flash disc I made for the SSD (although the utility can't detect the SSD).


I'm new to UEFI, so I'm not sure if there's some setting in here that I've missed.

The mobo is a Gigabyte Z87X-UD3H and the SSD is a Samsung 840 120GB.

The HDD that is being detected is a Hitachi 3TB, while the one that isn't is a WD 1TB that I've had for many years and used to be my boot drive.

Any suggestions?

TL: DR - SSD and 1TB drive not being detected by BIOS, 3TB and optical drive are. Also not booting from Windows install discs.
June 8, 2013 2:26:12 PM

Update

I bought a new DVD drive and a Kingston 60GB SSD. Both were recognized and worked and I was able to isntall Win7 alright. After a few hours of installing drivers and rebooting several times, I thought I finally had a stable and working system, so switched it off to fix up my cable management. When I tried to switch it back on, it failed to start. I started troubleshooting by disconnecting peripherals from the PSU and the SATA ports, and finally got it to start, but now the BIOS doesn't detect the Kingston SSD either.

I can't believe I have two brand new SSD's that have failed. I've emailed Gigabyte support, but I'm not expecting any response from them until next week.

I'm really at my wits end and really clutching for straws here. Is there anything I can do to get the BIOS to detect the SSD's? I've never had this many problems with a build before.
m
0
l
a b V Motherboard
June 8, 2013 3:23:52 PM

You might have connection issues with the cables. I have the same issue with an older motherboard. sata cables, if i 'bump' one, i loose the drive (cannot be detected). I have to reseat cables to get the drives working again.
(putting the cover on my computer bumps the cords).
m
0
l
Related resources
June 8, 2013 4:22:24 PM

Thanks, but I've already swapped both power and data cables several times and tried them on different sata and psu ports. I'm pretty sure the cables aren't the problem.

I just can't understand why the bios cant detect both SSD's and the 1TB HDD, but detects the 3TB HDD and DVD drives. It's possible the 1TB HDD has failed, it is the oldest, but I don't unnderstand why two brand new SSD's cant be detected.

Update: For clarity, I've also tried resetting the CMOS and rotating the RAM through the different slots. No difference. No reply yet from Gigabyte either.
m
0
l
June 9, 2013 2:49:37 AM

So for a first this to know as I've had the same issue,
Did you get a new CPU for the same motherboard or got everything new ?.
If the motherboard can be used with the same CPU as your old one, Change it back in taking the new one out replacing it with the old one and cheek if it load's up.
Then if it load's up go to the motherboards website and download the bios latest update then put it on a flash drive, restart your PC and go into bios settings, find the flash drive and install the new updated bios,(restart) let window's load up, a few more things will update and then once everything has finished updating you can turn off your computer and put in the new CPU, and it should work,

I have had this same every issue when I got a new CPU for my older board

Edited:With the ram only put 1 stick in it, not using more than 1 will help with some to most issue's, Tho I had no problems with installing window's with a full new build with 2 sticks of ram
m
0
l
June 9, 2013 3:54:36 AM

It's all new; Haswell 1150, so my old Sandy Bridge wouldn't fit. It's was dead anyway, necessitating the upgrade.

I have updated the BIOS to the latest version (f5), but that didn't help.

I'm wondering if maybe the issue might not just be the motherboard or if it's something more serious. I tested all of my drives in old Dell 8400 tonight, the only drive that the Dell's BIOS detected was the 3TB that my computer detects. Neither of the SSD's nor the 1TB was detected, which makes me wonder if there's something else that might be damaging the drives, as the Kingston apparently died after it wouldn't switch on, which could mean something was shorting out.

Is it possible the case could be creating a short which is damaging the drives? It's an NZXT Phantom 630, which mounts the SSD's behind the motherboard in metal trays that clip directly onto the motherboard tray. I've had the case for a few weeks now, but didn't have any problems until my old CPU and motherboard apparently died. I can't think of what could be creating a short, none of the cables appear to be damaged, and I've only used the supplied screws.

Monday is a public holiday here, but when I get to work on Tuesday, I'll borrow an external hub and do some more testing on the drives. On another note, I found a thread over on the Gigabyte Community Forums about other people with GA-Z87X-UD3H's having trouble with SSD's.
m
0
l
June 10, 2013 7:55:03 PM

Well, after testing with the external hub, it now appears that I might actually have three dead drives. Attaching the external hub to my laptop via usb, none of the drives show up in Windows Disk Management and the activity lights on the external hub don't illuminate.

I reconnected my good 3TB drive and the dvd drives yesterday and booted the computer with a linux distro on a flash drive. Not even linux was detecting the drives when I connected them. Doing more troubleshooting when reconnecting all the devices, I found that I had two SATA power cables that would prevent the computer from switching on when connected to a device (in this case, the DVD drives). Possibly the cables were creating a short which prevented the computer from switching on.

What I'm not sure about is how faulty power cables might kill a couple of drives that they weren't even connected to, but leave the connected devices undamaged? Or whether they could have damaged my original mobo, CPU and PSU? I'm hesitant about replacing the dead drives until I'm sure I know what killed them in the first place.
m
0
l
August 2, 2013 11:53:58 PM

am bumping you cause I have same problem , upgraded from i7 950 to 4770k with a z87x-oc force gigabyte mobo , yet I cant use them cuz my other 2 hard drives cannot be detected only the ssd which have windows on it
btw do you have windows installed in the 3tb drive which aren't dead apparently ??
m
0
l
August 3, 2013 12:38:05 AM

I have to reseat cables to get the drives working again.
m
0
l
October 24, 2013 5:05:59 PM

I am having this problem. Just got a i5-4670k and GA-Z87X-UD3H. Both new from Newegg. Have two 1TB hard drives and a 64GB OCZ Vertex SSD. All drives worked fine on previous system.

The BIOS only sees the SSD intermittently. I can boot the Win 7 DVD and install windows fine. Once I install the Gigabyte drivers from disk and reboot it fails to load Windows. sits at the "Starting Windows" image for minutes and then blue screens.

Reinstalled Windows again. Same thing. After a Windows first boot after install it runs fine. I can install drivers and download from the Web right after installing drivers.

Randomly when booting I am told it cannot find the Boot manager and the BIOS won't show the SSD. I moved all the sata cables and reseated. My board has F5 BIOS. Though I did download F7 I cannot install it since I cannot install .net 4 and then reboot. Any bout up after the initial install never works.

No clue what the heck is wrong.

UPDATE FIX FOUND: Okay, if you have a Z87 board with more than 6 Sata Ports you may be in luck. The original 6 SATA III ports are Intel based. The extra 2 on my board are Marvel based Sata II. My OCZ Vertex II WILL work properly on the Marvel sockets since they don't follow the tighter Intel Sata III parameters.
m
0
l
February 24, 2014 7:03:47 AM

Same issue - bought 3 Z87X-OC for office workstations (we needed quick, overclocked, machines). Drive is Corsair Force (SandForce 1xxx). Upgrading BIOS to F7 didn't help.
m
0
l
March 15, 2014 12:48:33 PM

Sorry but I am new to this board so I might get the etiquette wrong - apologies if I do.

But I have the same/similar issue.

Bought Z87X-UD3H and i5-4570 with 2 x Seagate Barracuda 2TB HDD's
System is constantly failing to see the drives and then seems to be OK after re-seating the cables - that part is just a real pain. I will try the Marvel sockets as suggested above, but that does negate the point of having a fast transfer.

However, since installation about a month ago 2 drives have now failed one an old Maxtor Diamondmax and one of the new Barracuda's now the 2nd Barracuda seems to be giving similar issues to the others prior to their failure. This can't be a drive issue.

Also it always seems to be the boot drive that is failing and I keep on having to re-install Windows from scratch other drives on the systems are working fine.

Please send me a life line I am going slowly mad here and I haven't got any hair left to pull out
m
0
l
!