Sign in with
Sign up | Sign in
Your question
Solved

Urgent Help With New Build!

Last response: in Components
Share
June 7, 2013 5:00:53 PM

Hi,

So this is my first time building a pc and I'm having an issue that I can't seem to resolve. So I put everthing together as best I could, but the computer wouldn't turn on. I tried removing the motherboard from the case and simply leaving in the ram, the processor, video card and power supply attached, but it still wouldn't turn on. Lights flash on the motherboard when I turn the power supply on or off, and the motherboard's power button indicates that it's on. None of the fans seem to work either. Not the cpu fan or the ones on the video card. I can't seem to get to the bios, and heard no beeps from the speaker. I'm worried that I may have damaged something, even though I tried to be really careful! Could someone help me out?

These are the specs:

Graphics card: ZOTAC GTX 770 2 GB DDR5
Processor: INTEL CORE I7-4770K 3.50GHZ LGA1150
Motherboard: MSI Z87 MPOWER MAX
Ram: GSKILL DDR3 8GB(4GB X 2)
Power supply: CORSAIR CX750 MODULAR

Thank you very much to anyone who can respond!

More about : urgent build

Best solution

a b V Motherboard
June 7, 2013 5:14:02 PM

Firstly: Nice rig.

Second, it could well be you've plugged things in incorrectly, if the fans aren't spinning.

I also hope you made sure not to touch the chips/circuitry or anything like; as they're not fond of human oils ^^.

Also always test things by placing the motherboard on the box it came with, before putting it in, as you're doing now.

I wonder if that PSU is Haswell certified...
Share
June 7, 2013 5:23:41 PM

My suggestion is same as X79, take everything out of the case and test on the mobo box. Something could also be caught underneath the Motherboard like a screw or something and might be interfering with the current. It's more than likely some cables not properly plugged.
m
0
l
Related resources
June 7, 2013 6:01:21 PM

First of all, thanks for replying so quickly. I have done as you both have suggested and I've pretty much checked that everything was plugged in correctly. This time though, when i turn on the power all the LEDs flash and the fans from the graphics card start spinning, but then stop after a second or so. And this time the power on LED on the motherboard isn't lit. And I tried my best not to touch any of the circuitry and lifting the Mobo by the heatsink, but I'm pretty sure I may have touched it. Thanks for the compliment on the rig. I'm guessing that when/if I get it running, it'll be beastly! :p 
m
0
l
June 7, 2013 6:04:58 PM

Oh, and I checked and apparently the psu should be compatible
m
0
l
June 8, 2013 6:43:36 AM

Thanks guys, didn't realise the graphics card required 2 PCI E connectors. The beast just roared to life. Again guys, thanks so much for the prompt response! Peace
m
0
l
a b V Motherboard
June 8, 2013 7:00:13 AM

Enjoy :) 
m
0
l
!