Sign in with
Sign up | Sign in
Your question

Sapphire 7870 hd black screen after installing catalyst driver.

Last response: in Graphics & Displays
Share
June 8, 2013 8:11:34 AM

Hello!
I've bought a new pc with the following specs:
Sapphire Radeon HD7870 2048MB DDR5/256bit DVI/HDMI PCI-E
Intel Core i5-3350P 3,10 GHz
ASRock B75 Pro3-M
Crucial 2x4GB Ballistix sport 1333MHz DDR3 CL9 NON-ECC DIMM 1.5V
Seagate 1TB, SATAIII, 7200RPM, 64MB cache
Thermaltake Smart SE Modular 530W

I've installed windows 7 on it with no problems. It has detected my card as a standart vga cart. I've downloaded and installed latest cataclyst drivers and after rebooting the pc after the windows logo the screen went black.

When i removed the driver in safe mode the system in device manager recognised the card correctly as hd 7870.

Ive tried the following measures with no result:
-using both dvi and hdmi ports
-reinstalling windows 7
-installing different versions of catalyst drivers (both different old ones and new beta ones)
-installing the driver using device manager function and targetting the amd folder
-installing windows 8- in which case the black screen appeared during its installation during "getting devices ready" screen
-flashing my bios to the newest version

After inserting and installing my old gpu : msi geforce 460 gtx everything works fine.

So here comes my question:
Is it a hardware problem with my 7870 and should i return it to the seller or should i troubleshoot some more?
Thanks in advance!

PS:English is not my native language so I hope everything is understandable.
June 8, 2013 8:15:58 AM

Yeah that is 90% a hardware issue as if your previous card is recognizable, this one should too. Means PCIE is selected in bios.

You should return it to retailer and get an exchange.
m
0
l
July 6, 2013 7:59:42 AM

Hello there, this is my first post in Tom's Hardware, which has often helped me.
I have the same problems since when I bought it (March 2013), and out of desperation, reverted back to Win XP.

German forums were FULL of this very same problem (I think this card sold a lot in Germany). Many suggested that it is a hardware problem / defect card: all the posts, however, were from March 2013.

However, after lurking these forums, it seems that it is positively a BIOS flash / update problem. The guy in this forum posted instructions (message #112):

http://www.computerbase.de/forum/showthread.php?t=11822...

Unfortunately, I never had time to do it, and stuck to Win XP. Above all, I am very lazy.
Note that several months after, people states they have flashed the BIOS and now it works.

I hope this helps, and I add a question on my own: anyone has a SIMPLE, bullet-list style answer to help me flashing the BIOS? what file/program do I need? That post says to tinker with USB flashcards, etc...


NOTE: I've seen your answer luckiest charm, and I reckon it. But somewhere I have seen that there was an ad-hoc BIOS update just tailor-made to that specific card. Just my 2 cents.

EDIT / Update: I am going to try THIS

http://www.techpowerup.com/vgabios/index.php?architectu...

Cheers again
Many thanks!
m
0
l
July 30, 2013 12:37:40 PM

By the way: it worked. I flashed the BIOS following the instructions of Computerbase and now I am finally playing with my Radeon under Win 7.
Kind regards,
Matteo
m
0
l
Related resources
!