Sign in with
Sign up | Sign in
Your question

Can't access my 1TB Buffalo external HD

Last response: in Storage
Share
June 12, 2013 5:44:35 AM

Hi guys,
I have issues with my ITB buffalo ext HD, I can see the blue light on the HD when connected to my laptop then green, but I can't access it since I the HD can't be seen in the "My computer" list of drives.

I hear a tiny noise every time I connect it but just for a few seconds.... Then silence.


I made this "video" (sorry for the quality) on youtube to help:
http://youtu.be/YE5hYQh-cBo

Thank you a lot it's really important cause I have all my work data on it :( (

Details:
S/N: 8971212501b7333
HD-PNTU3
I have tried 2 different PC, and tried another USB cable.
June 12, 2013 3:52:42 PM

either the hdd has failed or the usb to sata controller has. You will need another enclosure or drive dock to put the drive in to continue diagnosing the issue if you dont have a desktop pc you can use to mount the drive to the internal sata & power.

Removing the drive from the buffalo enclosure will void any warranty you may have left.
m
0
l
June 13, 2013 4:35:45 AM

Hi thank you for your reply!
I've bought a new case today with an integrated Sata, but still the same problem!! I have tried this new case in 2 different PC and always the same noise then nothing... What do you think? Is it physically damaged, and do you think that the recovery data can help?
Thanks!
m
0
l
!