Sign in with
Sign up | Sign in
Your question

MSI MS-7592 won't turn on after BIOS update

Last response: in Motherboards
Share
June 13, 2013 3:48:28 AM

I reinstalled WinXP on my mom's PC and after installing LiveUpdate, it offered a BIOS update. I ran it, after disabling the anti-virus, and it indicated that it completed successfully, but after rebooting, the PC wouldn't turn on anymore. After pressing the power button, CPU fan spins a bit, then waits for about 3 seconds, then ieverything turns on, but no POST (tried both the integrated and the PCIe graphics) and no HDD activity aside from spinning up. What could be the cause of this? Could LiveUpdate actually deliver the wrong BIOS? Any way to fix it?

Thanks in advance.
June 13, 2013 5:48:25 AM

Have you tried clearing the CMOS (unplug the power cord and remove the CMOS battery for few minutes)?
June 13, 2013 6:19:24 AM

Tried that too, just forgot to mention it. I waited for about 20 seconds, I can try again for a longer time in case the condensators keep the electricity for longer.

I would try the fail-safe force-update method if there is a possibility of it working. I have a floppy drive but no floppy diskettes, gotta find those.

http://rs.msi.com/service/bios-note/#for

UPDATE:

After taking out the battery and the power cord for some 5 minutes and then turning it on (without any peripherals, including the monitor) I noticed the HDD lamp working. When I connected the monitor, it was already in WinXP. After restarting it, same results as before: hitting the power button makes the CPU cooler spin for a second, wait for 3 seconds and then turns on, with no display output nor anything happening, as I can see the HDD lamp is not blinking.

I tried to reproduce the steps to turn it on with at least the keyboard plugged in for more than 40 minutes now, but no such luck. I'll try again with everything but the monitor disconnected, then everything disconnected.
!